xserver-xorg-input-wacom is version 0.31 and i need 0.30 for the wacom-dbg

Asked by Michael Clement

I am trying to get my wacom tablet to work on my 15.10 ubuntu. I was told it was supposed to work without me doing anything but it doesnt. When i run the command "sudo apt-get install wacom?" it returns saying that the package xserver-xorg-input-wacom-dbg depends on xserver-xorg-input-wacom (=1:0.30.0ubuntu3) but 1:0.31.0-6 is set to be installed!

i attempted to down grade my xserver-xorg-input-wacom package to 1:0.30.0ubuntu3 several different times with different methods but each time is said the same error message.

also it says that i have handled broken packages, even though i installed ubuntu only like 2 days ago, I only have installed a few things and havent messed around in the terminal much up until my tablet wouldnt work

Question information

Revision history for this message
Manfred Hampl (m-hampl) said :

Please provide the output of the following diagnostic commands:

uname -a
lsb_release -crid
sudo dpkg --audit
dpkg -l | grep wacom
apt-cache policy wacom xserver-xorg-input-wacom-dbg xserver-xorg-input-Wacom

Revision history for this message
Michael Clement (mclement389) said :

uname -a:
Linux michael-pc 4.3.0-5-generic #16-Ubuntu SMP Wed Dec 16 23:33:25 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

lsb_release -crid:
Distributor ID: Ubuntu
Description: Ubuntu Xenial Xerus (development branch)
Release: 16.04
Codename: xenial

sudo dpkg --audit:
[sudo] password for michael:
(AFTER entering password it didnt say anything else

dpkg -l | grep wacom:
ii libwacom-bin 0.17-1 amd64 Wacom model feature query library -- binaries
ii libwacom-common 0.17-1 all Wacom model feature query library (common files)
ii libwacom2:amd64 0.17-1 amd64 Wacom model feature query library
ii wacom-dkms 0.30.0-2 all Wacom kernel driver in DKMS format
ii xserver-xorg-input-wacom 1:0.31.0-6 amd64 X.Org X server -- Wacom input driver

apt-cache policy wacom xserver-xorg-input-wacom-dbg xserver-xorg-input-Wacom:
  Installed: (none)
  Candidate: 1:0.30.0-0ubuntu3
  Version table:
     1:0.30.0-0ubuntu3 500
        500 http://us.archive.ubuntu.com/ubuntu wily/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages
N: Unable to locate package wacom
N: Unable to locate package xserver-xorg-input-Wacom

Revision history for this message
Manfred Hampl (m-hampl) said :

Are you aware that you are not running Ubuntu 15.10, but version 16.04, which is the release currently in development (not even in Alpha stage yet)?


sudo dpkg --purge xserver-xorg-input-wacom
sudo apt-get install xserver-xorg-input-wacom xserver-xorg-input-wacom-dbg

Can you help with this problem?

Provide an answer of your own, or ask Michael Clement for more information if necessary.

To post a message you must log in.