Hanvon Artmaster AM1209 not recognised in 12.04lts

Asked by Martin Kyle

 0 down vote favorite

I'm totally lost.
I've just built a new system and installed Ubuntu 12.04lts. It's my first time with linux and getting into the terminal / command line for the first time since ibmdos 5 and windows 3.1 has been a steep learning curve.
However, the interface works beautifully apart from it doesn't recognise my Hanvon Artmaster AM1209.
I have sent diagnostics to Digimend and Favux was kind enough to advise that the tablet should be using the Wacom X driver as the Hanvon is actually a Hanwang and these should be supported.
lsusb reports: ID 0b57:8501 Beijing HanwangTechnology Co., Ltd
xinput list reports:
⎡ Virtual core pointer id=2 [master pointer (3)] ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)] ⎜ ↳ PS/2+USB Mouse id=8 [slave pointer (2)] ⎣ Virtual core keyboard id=3 [master keyboard (2)] ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)] ↳ Power Button id=6 [slave keyboard (3)] ↳ Power Button id=7 [slave keyboard (3)] ↳ Eee PC WMI hotkeys id=9 [slave keyboard (3)] ↳ AT Translated Set 2 keyboard id=10 [slave keyboard (3)]
Favux suggested inspecting /var/log/Xorg.0.log for the tablet but I can not see any mention of it, and that is as far as I have got. I've tried researching the problem but I am struggling with all the new terminology and the fact that I want the PC to be a means to an end and not the end in itself where I spend the rest of my days tweaking and testing rather than just using it.
Hope there is some help out there,

Question information

English Edit question
Ubuntu xf86-input-wacom Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best actionparsnip (andrew-woodhead666) said :
Revision history for this message
Martin Kyle (dm-kyle) said :

Thanks to actionparsnip for the message,
I have tried this driver in various forms but it doesn't seem to work. After insertion lsmod reports as follows:
Module Size Used by
hanvon 8290 0
I will try to get in touch with claw on that web site though.

Revision history for this message
Martin Kyle (dm-kyle) said :

Many, many thanks to CLAW for his time and patience. The driver on English version of the page linked by actionparsnip was a different version to the ones I'd tried before. Initially it gave button only input on the stylus, but a clean installation of Ubuntu appears to have done the trick and I have a functioning tablet. I think my blundering about with trying to solve this problem must have destabilized ubuntu.
Thanks again to ACTIONPARSNIP & CLAW

Revision history for this message
Martin Kyle (dm-kyle) said :

Thanks actionparsnip, that solved my question.