Quantal Quetzal Touchscreen Issues

Asked by Willy VVu

I'm using the Quantal Quetzal beta OS on a Lenovo X220 Tablet.

When I used Precise Pangolin, the touchscreen and pen worked. Now that I updated, they don't.

I looked under xinput and xsetwacom.

william@William-Thinkpad-X220:~$ xsetwacom --list
william@William-Thinkpad-X220:~$ xinput --list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ SynPS/2 Synaptics TouchPad id=11 [slave pointer (2)]
⎜ ↳ TPPS/2 IBM TrackPoint id=12 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Sleep Button id=8 [slave keyboard (3)]
    ↳ Integrated Camera id=9 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=10 [slave keyboard (3)]
    ↳ ThinkPad Extra Buttons id=13 [slave keyboard (3)]

Any idea as to what is going on?

P.S. I booted from a Precise live USB and the touchscreen worked fine.

I need help interpreting this:

william@William-Thinkpad-X220:~$ dmesg | grep wacom
[ 12.953728] usbcore: registered new interface driver wacom

Anything I can do?

Question information

English Edit question
Ubuntu xf86-input-wacom Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

I suggest you report a bug. Quantal is not stable and not ready for use.

Can you help with this problem?

Provide an answer of your own, or ask Willy VVu for more information if necessary.

To post a message you must log in.