Ubuntu 12.04 Precise Pangolin DomU on Xen 4.1 can't boot with Linux 3.2.0-25-generic

Asked by Wer Wie Was on 2012-06-26

I'm created a Dom0 with Xen 4.1 as hypervisor on Ubuntu 12.04 and created a new root filesystem (also 12.04 in paravirtualization mode) with debootstrap.

Then I wrote the Xen DomU configuration file and tried to boot the DomU with the 3.2.0-25-generic kernel. The DomU gets created but stucks in the boot process at the following sequence:

 7.179839] EXT3-fs (xvda1): mounted filesystem with ordered data mode
Begin: Running /scripts/local-bottom ... done.
done.
Begin: Running /scripts/init-bottom ... done.
fsck from util-linux 2.20.1
/dev/xvda1: clean, 15756/1310720 files, 215621/5242880 blocks

Seems to be a bug. In the Dom0/Xen logs are no errors reported. Other guests like Debian Squeeze work with the same kernel as DomU kernel. So I think its a problem with the kernel it self or with the interaction of the system with the kernel.

Does someone has a solution for this problem?

Best Regards

Best Regards

Other

Question information

Can you boot an older kernel?

Hello,

when I try to boot from the 3.2.0-23-generic kernel the boot process stucks in the same sequence but one step earlier. So the sequence looks like this:

5.862440] EXT3-fs (xvda1): mounted filesystem with ordered data mode
Begin: Running /scripts/local-bottom ... done.
done.
Begin: Running /scripts/init-bottom ... done.

Hello,

I have tested to boot with Kernel 3.2.0-23 to 3.2.0-25 (generic and virtual) and the 3.1.10 Mainline kernel but no kernel works. Don't know where the problem could be, I think that it's a problem by reading the filesystem.

Best Regards

Tal Fishler (tfishler) said : #4

This isn't really a bug.
The problem seems to be with the console redirection.

in Debian systems, you have to edit /etc/inittab so that you disable tty1 and enable hvc0 console instead. (hvc0 is the console for xen PV domU's)

In Ubuntu, just move /etc/init/tty1.conf to /etc/init/hvc0.conf and edit it so instead of tty1 it will reflect hvc0.

The weird thing is that it does not work when you put 'console=hvc0' as a kernel parameter or in the domU configuration file (As opposed to debian & centos)

tested with kernel 3.2.0-23 to and 3.2.0-26 and it worked like a charm.
Hope it helps.
Best regards.

Can you help with this problem?

Provide an answer of your own, or ask Wer Wie Was for more information if necessary.

To post a message you must log in.