Running local boot scripts

Asked by Kevin Murphy


I installed Xen on an Ubuntu 6.10 basic server install following these brief instructions:

On reboot, all seems to go well until the system gets to "Running local boot scripts (etc/rc.local)" then the cursor just hangs there, not scripts get run.

Thanks for any help.

Question information

English Edit question
Ubuntu xen-source-2.6.17 Edit question
No assignee Edit question
Solved by:
Frode M. Døving
Last query:
Last reply:
Revision history for this message
Frode M. Døving (frode) said :

Try to hit ctrl-c.
Does it continue to login?

Revision history for this message
Frode M. Døving (frode) said :

If it does, you can post the output of the following commands:

'sudo ls -lh /etc/rc.local'
'sudo cat /etc/rc.local'

That would be helpfull to understand why it's just hanging there.

- Frode

Revision history for this message
Kevin Murphy (kevinpatrickmurphy) said :

Thank you for the response!

Yes, it does move on to the login prompt at cntrl-c (or even, I have learned, if I hit the return key). So if I enter the command 'uname -r' I see I am in the xen kernel '2.6.17-6-generic-xen0'.
The output of 'sudo ls -lh /etc/rc.local' is:
'-rwxr-xr-x 1 root root 306 2006-11-25 20:50 /etc/rc.local'
With 'cat /etc/rc.local' I see why nothing happens... the script basically states "This script is executed at the end of each mutliuser runlevel. Make sure that the script will "exit 0" on success or any other value on error. In order to enable or disable this script just change the execution bits. By default this script does nothing."

I also seem to have a new problem. When I boot to the Xen kernel, I loose my network connectivity.

Revision history for this message
Best Frode M. Døving (frode) said :

That is another issue. Please open a separate request for that. If this problem is solved for you, please mark it as solved as per


- Frode

Revision history for this message
Kevin Murphy (kevinpatrickmurphy) said :

User confirmed that the request is solved.

Revision history for this message
rupert160 (rupert160) said :

Is this actually resolved? It seems that all that is happening is that Frode is simply exiting a process. I have the same issue at the moment. first time I booted in after a clean install I arrived with no Apache installed. I then reinstalled it, waited a little longer and fortunately had it installed. but how do I know there is nothing else broken? I too can ssh in etc and even exit a process. but i'm not confident that my ubuntu 7.04 server is fully functioning.

Revision history for this message
Michael Heča (orgoj) said :

I change in /etc/event.d/tty1 xvc0 to tty1 and promt on boot console is OK.