Networks on Xchat

Asked by Jareb on 2009-07-10

I've been using xchat on Ubuntu 8 for a while now and it has worked fine until right now. After clicking on the icon, it brings me to the Network List, which used to give me a list of networks. Now all of them are gone. How do I get them back? I haven't changed any of my settings and it worked fine this morning.

Thanks in advance.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xchat Edit question
Assignee:
No assignee Edit question
Solved by:
Jareb
Solved:
2009-07-22
Last query:
2009-07-22
Last reply:
2009-07-11
Josh Kupershmidt (schmiddy) said : #1

Jareb,

In the main XChat window, look in the top left of your window for menu item "XChat" -> "Network List". You should see a little checkbox inside this window which says "Skip network list on startup". Try unchecking this checkbox to make the Network List appear when you start XChat in the future.

Let me know if this is not what you were looking for.
Josh

Jareb (bittner66) said : #2

Hi Josh,
The box is unchecked. I get the Network List window, but in that window in the box that usually has lots of networks (titled Networks), there's nothing.

Josh Kupershmidt (schmiddy) said : #3

Jareb,
That's a little strange. I suspect what happened is that somehow the file containing the list of servers for XChat got wiped out. This file is ~/.xchat2/servlist_.conf

Try typing "cat ~/.xchat2/servlist_.conf" without the quotes in a Terminal window (Applications -> Accessories -> Terminal). If the file is empty, or missing, or corrupted, you could try creating a new file with that name and the following lines:

v=2.8.6

N=Ubuntu Servers
E=IRC (Latin/Unicode Hybrid)
F=19
D=0
S=irc.ubuntu.com/8001

Good luck
Josh

Jareb (bittner66) said : #4

Josh, that didn't work either, so I ended up just putting the server info for the only server I use directly into Xchat and it works fine now.