chars like æ,ø and å fails

Asked by Harlyman on 2006-01-24

Hi

i use xchat and language norwegian, all tekst i see when i talk to people on irc looks fine, but users that sees the text i write has problems with the chars æ-ø and å, the txt shows up like this: [10:50] <turbo> vi vil ha snø snø snø snø snø snø
in my client it looks like this: [10:50] <turbo> vi vil ha snø, snø, snø etc

any idea what to do do fix this problem, is the char support on linux that is the problem or is it the xchat??

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xchat Edit question
Assignee:
No assignee Edit question
Last query:
2006-01-24
Last reply:
2008-05-20
Olafur Arason (olafra) said : #1

Try xchat-gnome it should have better support for unicode, and is going to be default in Dapper. You should see Mac OS X.2 it has terrible support for this.

Simos Xenitellis  (simosx) said : #2

Indeed, using xchat-gnome (the default with GNOME), the text you write is in Unicode. Therefore, any Unicode-capable IRC client will be able to work.

You may encounter IRC clients that are not Unicode-capable, and their users will be at a loss. As long as it's Unicode, you are ok.

Judging by what the other users are seeing in their IRC client, Harlyman was already sending unicode. The problem seems to be rather with the people receiving his messages, who are using clients that blindy interpret unicode as some iso character encoding.

If Harlyman wants to fix this locally, what he would need to do is to configure his own xchat to NOT use unicode. I don't know how to do this, though, and generally it would be nicer if the other users would switch to unicode of course.

Xchat can use a hybrid ISO-8859-1 (aka Latin1) and UTF-8 encoding called IRC encoding. Using this special setting as the encoding for your IRC network should solve most problems both for unicode and windows clients that read your messages. AFAIK, xchat-gnome does not support this option.

Tommi Saira (tommisaira) said : #5

On finnish ceyboard layot äöå chartters shows up fine.

Can you help with this problem?

Provide an answer of your own, or ask Harlyman for more information if necessary.

To post a message you must log in.