xchat will not connect

Asked by Lunatek on 2006-01-05

xchat continuosly answers a connect command with unknown host maybe you misspelled it. This event occurs on a connect attempt to any server I try. I can connect using the same syntax with other clients . (windows mirc ). The xchat program will move to the next server with the same result.Ive ported my Linksys router to open 6667 .. this has no result.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu xchat Edit question
Assignee:
No assignee Edit question
Last query:
2006-01-22
Last reply:
2007-11-06
Stéphane Graber (stgraber) said : #1

Have you tried to connect directly to the IRC server ip to check if that's not a DNS problem ?

Stéphane Graber (stgraber) said : #2

Check also if you don't have case like "Use proxy to connect to this server" or "Use SSL" ticked (except if you really use these functions)

Dave Meikle (dmk-uk) said : #3

Following on from Stéphanes advice, Can you telnet into the IRC server?

For example: telnet irc.freenode.net 6667

If you can't it rules out XChat a points to your router/network setup, if it works we can concentrate on XChat.

Cheers,
Dave

Lunatek (robrichards) said : #4

Thanks I will try telnet ... Im using chatzilla for now and this works fine. Again all other internet functions are working properly but with xchat using ubuntu or knoppix neither will allow any irc connection to any irc server. Xchat worked great for awhile then just quit connecting

DesiArnez6 (bxdrza) said : #5

I am having the same problem described above. I tried to enter "irc.feenode.net" into Firefox, and nothing happened for a Very long time, eventually, maybe about 4 or 5 minutes. Then it redirects to "http://irc.freenode.net/apache2-default/" with a page that displays "It works!" in large black letters, upper left, with a blank background.

In the terminal (ubuntu 7.04) I typed "telnet irc.freenode.net 6667" It has been about 10 minutes and all I get is:
Trying 216.165.191.52...
Trying 208.71.169.36...
Trying 209.177.146.34...
Trying 213.92.8.4...
Trying 204.11.244.21...

Basically continues down the line with infinite IP addresses.

So I did a Traceroute
 heres the last part

 6 so-0-2-0.mpr2.dca2.us.above.net (64.125.26.105) 127.876 ms 123.636 ms 133.501 ms
 7 so-1-0-0.mpr3.iah1.us.above.net (64.125.28.50) 154.429 ms 159.896 ms 143.937 ms
 8 mpr2.lax9.us (64.125.25.18) 168.008 ms 207.747 ms 168.078 ms
 9 ge-vel-net.above.net (209.133.90.29) 228.092 ms * *
10 64.161.255.20 (64.161.255.20) 200.366 ms 195.832 ms 408.326 ms

Update, XChat has still not been able to connect, It has now ben almost 40 minutes. Rest of Internet is fine, AIM, Yahoo chat work fine.
Gaim Cannot connect to IRC though. I Don't see anything blocked error messages in port 6667 in Firestarter., so Im not sure what is going on.

Léo Studer (leo-studer) said : #6

I have exactly the same problem happening, information is very hard to find with regard to that subject.

Can you help with this problem?

Provide an answer of your own, or ask Lunatek for more information if necessary.

To post a message you must log in.