Webcam + dvbt in gutsy (07.08.08 and in hardy)

Asked by knuutsen

solved for hardy heron 8.04.1; see the link knuutsen at at the bottom of this page. On my blog there are also other solutions, especially for 64 bit hardy. Enjoy!

Hey there,

Im using gutsy and have a prob to get Webcam and DVBT working at the same time.

the Hardware:

dvbt = Hauppauge HVR - 900

Webcam = Creative Live! Cam Notebook Pro

If i make a separate installation all works fine:

HVR - 900 works with v4l-dvb-experimental (Repository: firmware.v3.tgz ; the blog for installation is written bei Konstantin in german; you can check it here: )

Creative Webcam works with gspca "out of the box". So i didnt have installed anything.

But if i try to work both together only dvbt works fine (with kaffeine) and the Webcam isnt found by gspca (lsusb is fine): here the results if i type in the terminal:
" sudo modprobe gspca"
"" FATAL: Error inserting gspca (/lib/modules/2.6.22-14-generic/kernel/drivers/usb/media/gspca.ko): Unknown symbol in module, or unknown parameter (see dmesg) ""

and dmesg tells me:
"" [ 1336.216000] gspca: disagrees about version of symbol video_devdata
[ 1336.216000] gspca: Unknown symbol video_devdata
[ 1336.216000] gspca: disagrees about version of symbol video_unregister_device
[ 1336.216000] gspca: Unknown symbol video_unregister_device
[ 1336.216000] gspca: disagrees about version of symbol video_device_alloc
[ 1336.216000] gspca: Unknown symbol video_device_alloc
[ 1336.216000] gspca: disagrees about version of symbol video_register_device
[ 1336.216000] gspca: Unknown symbol video_register_device
[ 1336.220000] gspca: disagrees about version of symbol video_device_release
[ 1336.220000] gspca: Unknown symbol video_device_release ""

If i deinstall v4l-dvb- experimental (so i kick my dvbt) than reboot and i have my Webcam back.....

I also found some sites, where the prob is described and where some guys try to fix it but until now unsolved. Here are those sites:

in german:
in english:
in english:

Some more detail infos

HVR - 900 uses /dev/video0

/dev/video1 not existing (but i guess its clear cause gspca isnt present) - here the results of "usbview" in terminal:

"" OHCI Host Controller "" says: ""Unknown device"" if i deinstall v4l-dvb-experimental than there is ""gspca"" and than all works fine.

if dvbt + Webcam...lsusb says:
Bus 002 Device 003: ID 041e:4051 Creative Technology, Ltd ## thats the webcam
Bus 003 Device 007: ID 2040:6500 Hauppauge

My solution isnt a real solution but it works:
Ive installed two headers the i386 and the generic. on i386 runs the webcam and on generic the dvbt. But i have to restart the system. Thats a really sucking methode.......

Please tell me what i have to do to get both working??????

Thanks for reply......

Question information

English Edit question
Ubuntu xawtv Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
knuutsen (peter-vornberg) said :

Hey there,

the last night i rethought about the prob. So i compiled a vanilla - kernel ( and started it. The advantage of the new kernel; no gspca build in this kernel like in the common kernel of gutsy. Than i installed v4l-dvb-experimental first and after a restart it works fine (without doing "sudo modprobe em28xx or sudo modprobe 2880-dvb" after the restart!). After that i installed the newest gspcav1 driver (24122007) and thats weird, i guess, cause i get the same results as with the 2.6.22-14 generic kernel described above. So my conclusion is; its not a kernel prob.


Hopefully the developer of gspcav and v4l-dvb-experimental read this. Why?

In my opinion its a compatibility prob between the two modules, cause they work with different symbols in video_devdata; *_device. Within this problem the v4l-dvb-experimental comes with its own v4l and that causes the probs with the symbols that gspcav needs, cause gspca expects other symbol registers.

Dont bother me, thats only what i think. For now i am still a rooky...yet.

If you have probs like that please answer me.

Revision history for this message
louis l'ancien (louis-penavaire) said :

Hi Knuutsen,
I also had a problem with gspca and v4l-dvb experimental (v4l-dvb-9a5a4b57cef4).
I use Kubuntu 7.1 and today I solve the problem like that :
* before installation of v4l-dvb I copy the file "/lib/modules/2.6.22-14-generic/kernel/drivers/media/video/videodev.ko" in my home
* I install v4l-dvb
* After installation, I replace the new file "/lib/modules/2.6.22-14-generic/kernel/drivers/media/video/videodev.ko" with the one I copied in my home.
After reboot the webcam and my usb dvb-t stick (pinnacle 72e) work fine together.
I hope it will be the same for you.

Revision history for this message
knuutsen (peter-vornberg) said :

Hi louis,

merci beaucoup, mais j' ai la meme probleme. Alors in english:

I did your proposals as you described.

First i've deinstalled v4l-dvb-experimental with sudo make rminstall.
Next i recompiled the linux - headers /images /restricted-modules in synaptic.

The only thing i can't remove ist the embedded gspca in kernel 2.6.22-14-generic. I dont know how....

After the restart i got my webcam back and dvb malfunction. Than i copied the videodev.ko as you described in my homefolder.
Than reinstalled v4l-dvb-experimental with make all and sudo make install and copied videodev.ko back "/lib/modules/2.6.22-14-generic/kernel/drivers/media/video".

The result: not gspca disagrees about symbols now it is em28xx which disagrees about lovely.

Any other ideas?

I have some questions to you?
 you wrote : v4l-dvb experimental (v4l-dvb-9a5a4b57cef4) thats an special v4l-dvb for your pinnacle i guess. How do i get it for my HVR-900?

Did you overwrite videodev.ko while you was copying or did you delete the v4l-dvb one before?

Did you create manually /dev/video0 or/and /dev/video1 ? Assuming that dvb and webcam needs them.
(you can do it with MAKEDEV)

Thank you very much for your answer and i appreciate your help further

Revision history for this message
knuutsen (peter-vornberg) said :

Hey Louis,
i have a very funny idea, so why don't you send me your videodev.ko, do you? I've located an extra account at yahoo for this help: <email address hidden>

Perhaps it works and i still wanna finish this prob.

I' m really sure that it's only videodev.ko which cause the problems. And you are using gspca and v4l-dvb as well.

Another try.....

Thanks for this unusual request


Revision history for this message
knuutsen (peter-vornberg) said :

Im again,
i think you cannot read the email; so here again ubuntu0366(et)yahoo(dot)com

Revision history for this message
louis l'ancien (louis-penavaire) said :

Hi Knuutsen,
I sent you an email at the adress you gave. I hope it will help you !

Revision history for this message
knuutsen (peter-vornberg) said :

Hi Louis,

it was a try. But it won't work this way for me. Do you know sites in france, which have the same prob, as described above, with my hardware devices?

Anyway i haven't enough knowledge solving this problem alone and it takes time to upgrade my knowledge.

Hopefully there is still a answer out there in the ubuntu / linux community.


Revision history for this message
louis l'ancien (louis-penavaire) said :

Hi Knuutsen,
Sorry that I didn't solve your problem.
I read a lot of posts (french, english, italian, and more difficult for me in german) concerning problems between gspca and v4l-dvb (not only your Hauppauge HVR-900). It seems that many people have this problem but I have never found a solution. I made my searches by using the keywords "gspca v4l-dvb" or "webcam v4l-dvb".
If I find a general solution to this problem, I will inform you.

Revision history for this message
knuutsen (peter-vornberg) said :

Hey Louis,

thank you very much for further support. Meanwhile i've found this site, which solved the problem. But for me it's too difficult following this few information. So i wrote George an email, for more detail information and perhaps a how to.

Here is the site:

If i get the information and it works i will post it here.


Revision history for this message
louis l'ancien (louis-penavaire) said :

Hi Knuutsen,
Thank you for this information. I understand the method, but I'm afraid to do this.
Of course a detailed howto would be interesting.
Good week-end !

Revision history for this message
knuutsen (peter-vornberg) said :

so after two weeks, i did not have any solution solving the problem. Besides i hope, that Markus Rechberger finished his work of the v4l-dvb-experimental into a release version he wrote in a email conversation half a year ago:
"The new driver will not need any internal API changes and also provide
the full flexibility, the current code I have looks promising and puts
some code into userspace.
In short - you will not have these problems anymore in future and make
kernel-links will not be needed soon :-)"

For so long i appreciate any ideas someone else might have in common.

PS: George has a solution ( see conversation above) but he didn't have time to write a blog yet...perhaps in future.

Revision history for this message
knuutsen (peter-vornberg) said :

It's done!!!

Many thanks to George!

Maybe it works for all of you who wants dvbt + webcam get working (e.g. at the same time)
It's recommended to follow gkiagias blog and reading my experiences and description to proceed successfully!

This description might be read as well in a few days at gkiagia's blog (date:11.02.2008):

Hey George,
you did a great job!!! I can't say it in words how lucky i am!
After days and weeks i solved the prob with your blog. Now i understand better how things get working in linux.
Many thanks for our email chat in the past.

To get it running on my system i have three more entries to compile as you described for the dvb devices above. So i will try to describe as exactly as i can to help other folks!

My Notebook (HP - NX6125; 1,8Ghz AMD-Sempron) and his two devices (HVR-900 (A1CO) Hybrid dvbt and the Webcam Creative Live! Notebook Pro) won't work together at the same time.That "was" the situation with the current delivered kernel in my distribution (Ubuntu gutsy 7.10 with kernel 2.6.22-14-generic).

Before getting started a hint, that works for me perfectly:
Go to synaptic and search for the "linux-source" depends on your current kernel, e.g. in my case it is "linux-source-2.6.22" with the installed version "2.6.22-14.51". If it's done finish synaptic and go on with Get started....

Get started:
1) Follow the instructions George described above. In the
  'menuconfig' you have three more changes to make and replace it
   with the entry "M".

   The path, where its located:
  “Device Drivers” -> “Multimedia Devices” -> “Video capture
  adapters” -> V4L USB devices ->

   Necessary changes to make:
   <M> Empia EM28xx USB video capture support
      <M> Empia EM288x/EM275x DVB-T support
      <M> Empia EM28xx USB Audio support

If changes made follow the blog.
I want to stop here to explain why it is strictly recommended to make these changes.

The first time i've followed the blog i thought i was successfull. After reboot i recompiled the gspca. I put the usb-devices webcam and dvbt in and dmesg looks like to get me lucky. I controlled the video devices in /dev/ and there was video0 and video1! I started Camorama with "camorama -d /dev/video1" and it worked! Than i started kaffeine (which has perfectly functioned with my old kernel and Martin Rechbergers v4l-dvb-experimental and for my dvbt specific firmware_v3.tgz) and my dvbt wasn't present. What a crap.
Than i had the idea to compare the dmesg output of my old kernel with the recompiled one and i located the prob: The "Analog Request" was recognized but not the "Digital Request". What does that mean? The answer: em28xx was installed for analog but not for digital. So thats the reason why i recompiled the kernel twice to get it working and therefore i need the "empia" modules to get it run.
If you use kaffeine,like me, you don't have to make the last step in gkiagias blog:
"mplayer -tv device=/dev/video0:driver=v4l2:norm=PAL-BG:chanlist=italy:
forceaudio:tdevice=/dev/vbi0:tlang=0 tv://"

That's it ! Enjoy both devices at the same time!

Some more hints (after recompiling and booting the recompiled kernel) might be useful:
For my Notebook [and especially for some others as well] i have to fix some things that worked before:

1. No WLAN (and how to fix it):

My old kernel works with ndiswrapper version 1.52 (my notebook requires it!)
To fix it for the recompiled kernel:
Go to your path where you have the data for the ndiswrapper.
In my case:
Than type:
sudo make install
sudo modprobe ndiswrapper

Open your network-manager (i prefer wicd and not the gutsy one) and search for your wlan network. Choose yours and get the connection.
So that's all what i had to do.

2. No gspca and how to fix it:

At my old kernel gspca runs well. For the recompiled one you must (re)install the gspca as well. So how do i do that?
I used the newest gspca before. On my computer its located in:
Type the following in:
sudo ./gspca_build

Now enjoy your webcam!
But recognize this:
if you put the webcam first in usb than it is located in /dev/video0
if you put in the dvbt first and the webcam as second than the webcam is located in /dev/video1!
Type in terminal: camorama -d /dev/video1

Remind yourself, when you use camorama!

kaffeine, i assume, looks always at /dev/video0 to grab the dvbt.
So remind the sequence; first dvbt and second webcam.
One more hint: skype 2.0 beta recognize automatically the right /dev/video*...:-)

3. No virtualbox and how to fix it
Thats the easy part, if you had installed virtualbox (e.g.1.5.4) at your old kernel.
Go to synaptics and search for virtualbox and click reinstall.
Finish synaptic and reboot your system.
Enjoy virtualbox!

At the end of this description i repead my thanks to George and his gkiagia's blog. Without his knowledge i couldn't have done this!


Revision history for this message
knuutsen (peter-vornberg) said :

Hey folks,

the problem is solved, and you can read it

a how to in german (wrote a blog on wordpress):

There you find a link for a english written solution to gkiagia's blog and my description there for solving the problem with HVR-900 + Creative Webcam Live! Notebook Pro and perhaps for all other combination of dvbt + webcam devices using the v4l-dvb-tree for dvbt.

Please tell us your experiences with the solution we discovered there and leave a message at Knuutsen's Blog or Gkiagia's Blog.

Hopefully it helps you solving your problem with those devices.