Compiling xawtv under Ubuntu Karmic

Asked by Gabriel Huecas on 2010-03-11

Hello,
I am trying to compile xawtv under Ubuntu Karmic. I downloaded xawtv_3.95.dfsg.1.orig.tar.gz
 and applied patches from xawtv_3.95.dfsg.1-8.1ubuntu1.diff.gz.

Any version of xawtv I tried to compile report the same bug:

In file included from console/fbtv.c:44:
console/fs.h:2:20: error: FSlib.h: No such file or directory

(there are a number of irrelevant warnings)

The include of FSlib.h in fs.h file is:
# include <FSlib.h>

However, I installed libfs-dev package which installs FSlib.h under /usr/include/X11/fonts, so the file fs.h is not found.
Even if I change this line, then the linker does not find the library.

I configured the sources with "./configure" and "./configure --with-x" with the same results.
I compiled xawtv-0.95 from other sources and all of them give the same error.

How can I compile xawtv? Do I need any further library or any additional option for "./configure"?

(I enclose below the output of "./configure" in the case you need it)

Thank you very much,

Gabriel Huecas

OUTPUT OF "./configure:
$ ./configure
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking how to run the C preprocessor... gcc -E
checking for a BSD-compatible install... /usr/bin/install -c
checking for gccmakedep... gccmakedep
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking getopt.h usability... yes
checking getopt.h presence... yes
checking for getopt.h... yes
checking soundcard.h usability... no
checking soundcard.h presence... no
checking for soundcard.h... no
checking for unistd.h... (cached) yes
checking sys/select.h usability... yes
checking sys/select.h presence... yes
checking for sys/select.h... yes
checking sys/soundcard.h usability... yes
checking sys/soundcard.h presence... yes
checking for sys/soundcard.h... yes
checking alsa/asoundlib.h usability... yes
checking alsa/asoundlib.h presence... yes
checking for alsa/asoundlib.h... yes
checking linux/joystick.h usability... yes
checking linux/joystick.h presence... yes
checking for linux/joystick.h... yes
checking dev/ic/bt8xx.h usability... no
checking dev/ic/bt8xx.h presence... no
checking for dev/ic/bt8xx.h... no
checking machine/ioctl_bt848.h usability... no
checking machine/ioctl_bt848.h presence... no
checking for machine/ioctl_bt848.h... no
checking for ftello... yes
checking for fseeko... yes
checking for getpt... yes
checking for getnameinfo... yes
checking for getopt_long... yes
checking for strcasestr... yes
checking for dlopen... no
checking for dlopen in -ldl... yes
checking for ELF... yes
checking for pthread_create in -lpthread... yes
checking for main in -lossaudio... no
checking for initscr in -lncurses... yes
checking for X... libraries , headers
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking for Xft... yes
checking for jpeg_start_compress in -ljpeg... yes
checking for snd_seq_open in -lasound... yes
checking for lirc_init in -llirc_client... yes
checking for vbi_capture_fd in -lzvbi... yes
checking for aa_autoinit in -laa... yes
checking for dv_decoder_new in -ldv... no
checking for lqt_query_registry in -lquicktime... no
checking for XF86DGAQueryExtension in -lXxf86dga... yes
checking for XF86VidModeQueryExtension in -lXxf86vm... yes
checking for DPMSQueryExtension in -lXdpms... no
checking for DPMSQueryExtension in -lXext... yes
checking for XineramaQueryExtension in -lXinerama... yes
checking for XRenderQueryExtension in -lXrender... yes
checking for XRRConfigCurrentConfiguration in -lXrandr... yes
checking for XvQueryExtension in -lXv... yes
checking for XmStringGenerate in -lXm... no
checking for glXChooseVisual in -lGL... yes
checking for X11 config directory... /etc/X11
checking for X11 app-defaults directory... /etc/X11/app-defaults
checking if mmx should be used... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: creating xawtv.spec
config.status: creating config.h
config.status: config.h is unchanged

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu xawtv Edit question
Assignee:
No assignee Edit question
Solved by:
Gabriel Huecas
Solved:
Last query:
Last reply:
john (no2498) said : #1

if i read you right you are trying to install xawtv
910 has it in the add/remove
on my computer with 910 i can get it loaded but it will not startup it tries but just closes
hope this helps

Gabriel Huecas (gabriel-dit) said : #2

Hi John,
xawtv installs and runs ok in my 910.
I am trying to compile and install it from the sources.
Actually, I could compile it with the following line:

./configure --x-includes=/usr/include/X11/ --x-libraries=/usr/lib/X11/

and editing the Makefile to remove references to X11R6: in line 32 of Makefile :

X11_FLAGS := -I/usr/include/X11/ -I/usr/include/freetype2 -I/usr/X11R6/include/X11/fonts

I change this line for

X11_FLAGS := -I/usr/include/X11/ -I/usr/include/freetype2 -I/usr/include/X11/fonts

(Note: "./configure --with-x results in compiling error due to FSlib.h missing header)

However, two errors/bugs more:

1) in file "console/fbtools.c", line 24:

#include <asm/page.h>

I changed this for

#include <sys/user.h>

2) In file "console/matrox.c", line 12:
#include <asm/page.h> /* PAGE_SIZE */

I changed this for
#include <sys/user.h> /* PAGE_SIZE */

With this I can compile xawtv. After installing it, I still have several minor problems, the most important is that

It does not display an OV511 camera (which returns V4L2_PIX_FMT_OV511, a special jpeg crompression format)

However, the xawtv installed from the Ubuntu repository properly displays this camera.

So coming back to my main question: how is xawtv compiled in the Ubuntu Karmic distro so it can compile, and then display this camera?

thank you very much

Gabriel Huecas

Gabriel Huecas (gabriel-dit) said : #3

Well, I manage to get ride of the configuration problems from compiling xawtv, applying the patches from xawtv_3.95.dfsg.1-8.1ubuntu1.diff.gz

(After applying it, several additional patches appear, I applied 02_xorg7.dpatch, which solves the problem with the FS fonts (X11R6 path removed) and 07_page_size.dpatch (which solves the fbtools.c and matrox.c problem).

So now I am happy as I can compile.
However, running the xawtv still does not recognize the OV511 pixel format. Any help is warmly welcomed.

Gabriel
P.D. I made the questions, I answered them...

Gabriel Huecas (gabriel-dit) said : #4

Ouch, I got it!
I applied the patches :

100_fedora-v4l2-fixes.dpatch
101_fedora-nodga.dpatch
102_fedora-use_libv4l.dpatch

and now it works fine :-) (well, I am fairly sure that the patches that solves the problem is the last one)

Gabriel

Gabriel Huecas (gabriel-dit) said : #5

Ouch, I got it!
I applied the patches :

100_fedora-v4l2-fixes.dpatch
101_fedora-nodga.dpatch
102_fedora-use_libv4l.dpatch

and now it works fine :-) (well, I am fairly sure that the patches that solves the problem is the last one)

Gabriel