xkill no longer in x11-utils

Asked by Iľja Pelech

Hi, folks!

I noticed, Xkill got removed from the x11-utils package in 18.04.

Is this intentional?

What should I use as an alternative?


Question information

English Edit question
Ubuntu x11-utils Edit question
No assignee Edit question
Solved by:
Manfred Hampl
Last query:
Last reply:
Revision history for this message
Best Manfred Hampl (m-hampl) said :

According to https://packages.ubuntu.com/bionic/amd64/x11-utils/filelist the program is still there (note the name xkill and not Xkill).

For diagnostic purposes please provide the output of the commands

uname -a
lsb_release -crid
apt-cache policy x11-utils

(Remark: You have to be aware that there are restrictions on running X utilities on Wayland.)

Revision history for this message
Iľja Pelech (ilja-pelech) said :

Thanks Manfred Hampl, that solved my question.

Revision history for this message
Iľja Pelech (ilja-pelech) said :

I must have been blind not to see it. For some reason, I couldn't run it from gnome-shell using the run dialog and didn't try shell (can't figure out why I didn't).