TATA Indicom USB CDMA modem

Asked by avinash!!!! on 2009-05-22

i have a tata indicom usb cdma modem

to install its drivers in linux versions in i'm asked to run

 wvdialconf /etc/wvdial.conf

the ouput i get for above cmd is

Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

Modem Port Scan<*1>: S0 S1 S2 S3
WvModem<*1>: Cannot get information for serial port.
ttyACM0<*1>: ATQ0 V1 E1 -- OK
ttyACM0<*1>: ATQ0 V1 E1 Z -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyACM0<*1>: Modem Identifier: ATI -- ERROR
ttyACM0<*1>: Speed 4800: AT -- OK
ttyACM0<*1>: Speed 9600: AT -- OK
ttyACM0<*1>: Speed 19200: AT -- OK
ttyACM0<*1>: Speed 38400: AT -- OK
ttyACM0<*1>: Speed 57600: AT -- OK
ttyACM0<*1>: Speed 115200: AT -- OK
ttyACM0<*1>: Speed 230400: AT -- OK
ttyACM0<*1>: Speed 460800: AT -- OK
ttyACM0<*1>: Max speed is 460800; that should be safe.
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK

Found an USB modem on /dev/ttyACM0.
Modem configuration written to /etc/wvdial.conf.
/etc/wvdial.conf<Warn>: Can't write '/etc/wvdial.conf.tmp7590': Permission denied
/etc/wvdial.conf<Warn>: Can't write '/etc/wvdial.conf' ('/etc/wvdial.conf'): Bad file descriptor
ttyACM0<Info>: Speed 460800; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"

and after that i'm asked to edit /etc/wvdial.conf to specify the phonenumber, login name, and password of
 internet account in order for wvdial to work.

User should edit the configuration file

as given below.

[Dialer Defaults]
Modem = /dev/ttyACM0
Baud = 460800
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2
+FCLASS=0
ISDN = 0
Modem Type = USB Modem
Phone = #777
Username = internet
Password = internet
stupid mode = 1

but i'm not able to edit that .conf file
it says

Could not save the file /etc/wvdial.conf.
you donot have permissions nessacery to ssave the file
please check you typed the location correctly and try again

please help me regardin what i should do with problem

thank you
avinash

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu wvdial Edit question
Assignee:
No assignee Edit question
Solved by:
Steven Danna
Solved:
Last query:
Last reply:
Steven Danna (ssd7) said : #1

You need to take on administrator privileges to edit that file. From the command line edit it with the following command:

gksudo gedit /etc/wvdial.conf

avinash!!!! (gbavinash89) said : #2

thanks for ur reply .....
ive edited wvdial file but ....
to start the internet connection i need to give

wvdial command :

in the output i'm gettin some error ......

the output is as follows

--> WvDial: Internet dialer version 1.60
--> Cannot open /dev/ttyACM0: No such file or directory
--> Cannot open /dev/ttyACM0: No such file or directory
--> Cannot open /dev/ttyACM0: No such file or directory
adp@adp-laptop:~$ wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2
ATQ0 V1 E1 S0=0 &C1 &D2
OK
--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
CONNECT
--> Carrier detected. Starting PPP immediately.
--> Unable to run /usr/sbin/pppd.
--> Check permissions, or specify a "PPPD Path" option in wvdial.conf.

please suggest me wat to do regarding this error (last two lines)

thank you
-avinash-

Best Steven Danna (ssd7) said : #3

I believe you will have to run wvdial as sudo as follows:

sudo wvdial

If you still see errors, you might want to consult
https://help.ubuntu.com/community/DialupModemHowto/SetUpDialer?action=show&redirect=Wvdial

You can also feel free to ask about them here; however, the guide
looks rather helpful.

avinash!!!! (gbavinash89) said : #4

thanks for your reply ...
can you please tell me wat does the last line in wvdial command output

it says

Check permissions, or specify a "PPPD Path" option in wvdial.conf.

what should i specifiy for PPPD Path in wvdial.conf file

thank you
-avinash-

Steven Danna (ssd7) said : #5

Does that error still come up when running wvdial with sudo? Given
the wording of the command, I would assume it wants the path to pppd.

If you run the following command:

sudo which pppd

It will output the path of pppd. On my machine this is in
/usr/sbin/pppd which can only be run by root which is why I suggested
you run sudo wvdial rather than wvdial.

avinash!!!! (gbavinash89) said : #6

i have the following output for wvdial :

--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2
ATQ0 V1 E1 S0=0 &C1 &D2
OK
--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
CONNECT
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Sun May 24 02:25:05 2009
--> Pid of pppd: 5969
--> Using interface ppp0
--> pppd: �7g[08]P6g[08]
--> pppd: �7g[08]P6g[08]
--> pppd: �7g[08]P6g[08]
--> pppd: �7g[08]P6g[08]
--> pppd: �7g[08]P6g[08]
--> local IP address 121.245.13.253
--> pppd: �7g[08]P6g[08]
--> remote IP address 172.23.129.14
--> pppd: �7g[08]P6g[08]
--> primary DNS address 203.197.12.30
--> pppd: �7g[08]P6g[08]
--> secondary DNS address 202.54.1.18
--> pppd: �7g[08]P6g[08]

but the internet still doesnt work

Steven Danna (ssd7) said : #7

It seems that your ppp connection is up. Try the following to get your internet applications working. This is taken from the link that I posted above:

Run the command: gksudo gedit /etc/ppp/options

Find lcp-echo-interval30 and lcp-echo-failure4. Comment out these options by adding a '#' at the start of these lines, eg. # lcp-echo-interval30 and # lcp-echo-failure4.

If you connect successfully but your Internet applications do not function (eg. web pages do not load in Firefox), you might need to add replacedefaultroute as a new line in the pppd option file.

avinash!!!! (gbavinash89) said : #8

thank you steven danna.....

its working with sudo wvdial command ....

avinash!!!! (gbavinash89) said : #9

Thanks Steven Danna, that solved my question.