Why usb-edge modem (pl2303) using WVDIAL is not working in Ubuntu 12.04?

Asked by Khalil azim on 2012-08-18

I use a USB EDGE modem for connecting internet in XP & Linux. Previously in Ubuntu it was detected as Prolific pl2303 converter and with WVDIAL I used internet without any problem. Recently I upgraded to 12.04 and my modem just stop working. lsusb shows the device and dmesg confirms that it is attached to ttyUSB0 but when I give command wvdial then nothing happens. A message appears "modem not responding". I did not change any settings but its just not working. What can I do now?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu wvdial Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:

Can you give the output of:

lsb_release -a; uname -a; lsusb

Thanks

Khalil azim (khalilazim) said : #2

Sorry for my late response. I m providing required informations.

rony@my-linuxxx:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise

rony@my-linuxxx:~$ uname -a
Linux my-linuxxx 3.2.0-23-generic-pae #36-Ubuntu SMP Tue Apr 10 22:19:09 UTC 2012 i686 i686 i386 GNU/Linux

rony@my-linuxxx:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 006: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port

Khalil azim (khalilazim) said : #3

I have completed a full upgrade of my system. Now the outputs are little different but my problem remains same.

rony@my-linuxxx:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise

rony@my-linuxxx:~$ uname -a
Linux my-linuxxx 3.2.0-29-generic-pae #46-Ubuntu SMP Fri Jul 27 17:25:43 UTC 2012 i686 i686 i386 GNU/Linux

Try:

echo "options usbserial vendor=0x4348 product=0x5523" | sudo tee /etc/modprobe.d/usbserial.conf > /dev/null
echo "usbserial" | sudo tee -a /etc/modules > /dev/null

Reboot to test

Source:
http://forums.reprap.org/read.php?12,4546

Khalil azim (khalilazim) said : #5

I tried but no result.

It seems to me some kind of kernel problem. Previously I installed WVDIAL then input the command "sudo modprobe pl2303", edit /etc/modules with pl2303, finally gave the command WVDIAL after editing /etc/wvdial.conf file. This process worked fine. After upgraded to 12.04 this is not working.

A point to be noted that, I am now using another edge usb-modem (HUAWEI) which is detected as option. I use the same procedure just replacing pl2303 with option and it works without any problem at all.

Khalil azim (khalilazim) said : #6

I test this scenario in ubuntu 10.04. Works fine, no problem.
Then I test it differently. I used Debian 6.0.1, no problem but in Debian when I upgraded to 6.0.5 the problem starts. It seems that some or any change between 6.0.1 and 6.0.5 is the issue.

In Ubuntu I last used 10.04, I m not sure from which distribution among 10.10, 11.04 & 11.10 the problem begins in Ubuntu. In my count, the distro may be 11.10.

Khalil azim (khalilazim) said : #7

I have identified the problem. Its inside the kernel. As I also faced this problem with Debian, I used Debian 6.0.1 to pinpoint the problem. I install Debian 6.0.1 and then try to update the system. After updating the repository I only update the Kernel. The original Kernel was 2.6.32-31 and after updating the Kernel version is 2.6.32-45. Just after updating the Kernel the problem starts. So, this problem is inside the kernel. Now what to do?

I suggest you report a bug

dcialdella (dcialdella) said : #9

I have the same problem in Ubuntu 13.10 64 bits.
And I guess is the kernel, or pl2303 module or something related "IN" the O.S.

Can you help with this problem?

Provide an answer of your own, or ask Khalil azim for more information if necessary.

To post a message you must log in.