wifi connection in recovery mode

Asked by Giacomo Mazzocato on 2009-12-06

(Ubuntu 9.10) If I boot in recovery mode I can't get my wireless connection, which works well when using network manager.
I'm using wep authentication. If I stop network manager when on gnome and use this /etc/network/interface
auto lo
iface lo inet loopback

iface wlan0 inet dhcp

wireless-key ********
wireless-essid dlink_tosca
auto wlan0
a than do a /etc/init.d/networking restart
it works (without using wpa_supplicant as I can see by /var/log/syslog)

but if I do the same while on recovering mode it doesn't ,and this is what I see in /var/log/syslog:
Dec 6 19:18:08 pako-desktop kernel: [ 159.537312] ADDRCONF(NETDEV_UP): wlan0: link is not ready
Dec 6 19:18:08 pako-desktop kernel: [ 159.539484] wlan0: direct probe to AP 02:1e:58:41:db:da try 1
Dec 6 19:18:08 pako-desktop kernel: [ 159.543960] wlan0 direct probe responded
Dec 6 19:18:08 pako-desktop kernel: [ 159.543965] wlan0: authenticate with AP 02:1e:58:41:db:da
Dec 6 19:18:08 pako-desktop kernel: [ 159.556999] wlan0: authenticated
Dec 6 19:18:08 pako-desktop kernel: [ 159.557003] wlan0: associate with AP 02:1e:58:41:db:da
Dec 6 19:18:08 pako-desktop kernel: [ 159.570881] wlan0: RX AssocResp from 02:1e:58:41:db:da (capab=0x411 status=0 aid=1)
Dec 6 19:18:08 pako-desktop wpa_supplicant[866]: No network configuration found for the current AP
Dec 6 19:18:08 pako-desktop wpa_supplicant[866]: CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
Dec 6 19:18:08 pako-desktop kernel: [ 159.570885] wlan0: associated
Dec 6 19:18:08 pako-desktop kernel: [ 159.571790] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Dec 6 19:18:08 pako-desktop kernel: [ 159.572240] wlan0: disassociating by local choice (reason=3)

it seems that iwconfig sets the wlan0 interface correctly but wpa_supplicant doesn't like it
is there a way to disable wpa_supplicant in recovery mode (when in gnome it doesn't bother disconnect)
I have tried to remove the wpa_supplicant ifupdown.sh links in /etc/network/*.d but it doesn't work

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu wpasupplicant Edit question
Assignee:
No assignee Edit question
Solved by:
Giacomo Mazzocato
Solved:
Last query:
Last reply:
Revision history for this message
Rohan Kapoor (rohankapoor) said :
#1

From what I have found, I don't believe recovery mode loads the restricted drivers as my wifi card suffers the same problem. I believe this is normal behavior.

Revision history for this message
Giacomo Mazzocato (gmazzocato) said :
#2

but it must be possible to get network support in recovery mode, what happens if I need to reinstall a package (that happened to me). Perhaps do i have to load some kernel module ? it seems strange to me

Revision history for this message
Rohan Kapoor (rohankapoor) said :
#3

I agree it is rather odd. It just seems that restricted drivers are the ones not loaded. My ethernet drivers load fine but the wifi ones don't

Revision history for this message
Giacomo Mazzocato (gmazzocato) said :
#4

I have found a workaround (stop networkmanager).
when in recovery mode at the console prompt type:
service network-manager stop
uncomment the parts regarding wlan0 int /etc/network/interfaces , in my case uncomment the following lines :

#iface wlan0 inet dhcp

#wireless-key ********
#wireless-essid dlink_tosca

#auto wlan0
than type
/etc/init.d/networking restart
and the network is up!
when you have finished recomment those lines and type
service network-manager start

Revision history for this message
Rohan Kapoor (rohankapoor) said :
#5

Glad that you were able to solve your problem. Please close this question now.

Revision history for this message
Giacomo Mazzocato (gmazzocato) said :
#6

ok