Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01) wireless not working in Ubuntu 8.10

Asked by ranbrody on 2009-01-02

Binary package hint: firefox-3.0

i installed ubuntu 8.10 but my wireless connection has been disabled

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 8.10
NonfreeKernelModules: wl
Package: firefox-3.0 3.0.5+nobinonly-0ubuntu0.8.10.1
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.27-9-generic x86_64

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu wireless-tools Edit question
Assignee:
No assignee Edit question
Last query:
2009-01-02
Last reply:
2009-04-17
ranbrody (jrranbrody) said : #1
Bernhard (b.a.koenig) said : #2

Do you have a network symbol in your system tray (upper right)? If so, what happens if you click on it? If your wireless card is enabled, you should see a list of wireless connections to choose from.

Chris Crisafulli (itnet7) said : #3

Thanks for reporting your issue and helping make Ubuntu better. Can you please provide more details ? Can you attach the output of lspci, se we can know what specific wireless card it is that you're trying to get to work? Can you put the laptop Brand and Model number? Did you have ubuntu 8.04 on here previously? If so, did wireless work there without issue? Thanks for any extra information you are able to provide!

Chris

ranbrody (jrranbrody) said : #4

here is an output of the lspci. and i had 8.04 before but i couldn't connect wireless either. i have a Dell Inspiron 1501. if you have any questions i will be glad to answer them.

00:00.0 Host bridge: ATI Technologies Inc RS480 Host Bridge (rev 10)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:05.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:06.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 14)
00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc RS482 [Radeon Xpress 200M]
05:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)
08:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
08:01.0 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)
08:01.1 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 01)

ranbrody (jrranbrody) said : #5

here is an output of the lspci. and i had 8.04 before but i couldn't connect
wireless either. i have a Dell Inspiron 1501. if you have any questions i
will be glad to answer them.

00:00.0 Host bridge: ATI Technologies Inc RS480 Host Bridge (rev 10)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:05.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:06.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 14)
00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc RS482 [Radeon Xpress
200M]
05:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev
01)
08:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev
02)
08:01.0 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host
Adapter (rev 19)
08:01.1 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 01)

Bernhard (b.a.koenig) said : #6

Hi,

if you still have problems with this issue, maybe you should ask a question in the "answer" section. I know that there is many questions about getting wireless to work and they usually get answered over there.

It's probably a driver issue and not a bug, so I'll close this. As I said, feel free to ask a question regarding this issue if you still have problems.

John Vivirito (gnomefreak) said : #7

Converted to a question for reporter.

hafuruchi (hafuruchiogadinma) said : #9

My wireless network is not working properly.

I installed a broadcom 802.11b/g WLAN in my laptop and it still cannot see the wireless router which every other computer is seeing.What could be the problem? how do i solve it?

I have the same problem now with Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01) no longer working after the new update.

Ubuntu 11.4
Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01) can not connect to WiFi.
Tried additional Driver as per recommendation
Ref
This package contains Broadcom 802.11 Linux STA wireless driverfor use with Broadcom's BCM4311-, BCM4312-, BCM4313-, BCM4321-,BCM4322-, BCM43224-, and BCM43225-, BCM43227- and BCM43228-basedhardware.

All wireless facilities became disabled. Situation worse.

I am willing to try anything.

Thank You

I tried
1) sudo apt-get --purge remove b43-fwcutter
2) reboot
3) sudo apt-get install b43-fwcutter (confirm firmware download)
4) reboot
With reboots.
No joy

Can you help with this problem?

Provide an answer of your own, or ask ranbrody for more information if necessary.

To post a message you must log in.