Lost my wifi connection

Asked by tomw on 2008-01-14

have 7.10 with edimax card with RT61 chipset. It worked fine for monts and no no wlan detected. Iw config shows no wireless connections. In the past it was wlan0.

tommeke@tommeke-desktop:~$ sudo ifup -a
[sudo] password for tommeke:
Ignoring unknown interface eth1=eth1.
Ignoring unknown interface eth2=eth2.
Ignoring unknown interface ath0=ath0.
ra0: ERROR while getting interface flags: No such device
Error for wireless request "Set Encode" (8B2A) :
    SET failed on device ra0 ; No such device.
Error for wireless request "Set ESSID" (8B1A) :
    SET failed on device ra0 ; No such device.
There is already a pid file /var/run/dhclient.ra0.pid with pid 134519120
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

SIOCSIFADDR: No such device
ra0: ERROR while getting interface flags: No such device
ra0: ERROR while getting interface flags: No such device
Bind socket to interface: No such device
Failed to bring up ra0.
wmaster0: ERROR while getting interface flags: No such device
There is already a pid file /var/run/dhclient.wmaster0.pid with pid 134519120
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

SIOCSIFADDR: No such device
wmaster0: ERROR while getting interface flags: No such device
wmaster0: ERROR while getting interface flags: No such device
Bind socket to interface: No such device
Failed to bring up wmaster0.
wlan0: ERROR while getting interface flags: No such device
Error for wireless request "Set Encode" (8B2A) :
    SET failed on device wlan0 ; No such device.
Error for wireless request "Set ESSID" (8B1A) :
    SET failed on device wlan0 ; No such device.
There is already a pid file /var/run/dhclient.wlan0.pid with pid 134519120
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

SIOCSIFADDR: No such device
wlan0: ERROR while getting interface flags: No such device
wlan0: ERROR while getting interface flags: No such device
Bind socket to interface: No such device
Failed to bring up wlan0.
tommeke@tommeke-desktop:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

tommeke@tommeke-desktop:~$ iwlist scan
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu wireless-tools Edit question
Assignee:
No assignee Edit question
Last query:
2008-01-15
Last reply:
2008-01-18
Robert Di Gioia (digioiar) said : #1

Hi.

You might want to see if the system is recognizing the adapter at all. To do this, type the following command. It will ask for your password, type it in and press enter even though you won't see anything while typing the password, it is ok.

sudo lshw -C network | less

You can also look through syslog and see if there are any error messages related to the edimax card while booting. There are many ways to do this, one way to do this is to type

dmesg | less

and then while in less type /ireless

yes, a slash, followed by wireless without the w :)

Good luck, and hope it helps

tomw (twauters) said : #2

Hi Robert

after dmesg got following message

ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
[ 16.480459] ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 10 *11 12
14 15)
[ 16.480552] ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 10 11 12
14 15) *0, disabled.
[ 16.480643] ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 7 *10 11 12
14 15)
[ 16.480758] ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 10 *11 12
14 15)
[ 16.480848] ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 7 10 *11 12
14 15)
[ 16.480954] ACPI: PCI Interrupt Link [LNKF] (IRQs *3 4 5 6 7 10 11 12
14 15)
[ 16.481046] ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 6 7 10 11 12
14 15) *0, disabled.
[ 16.481138] ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 *5 6 7 10 11 12
14 15)
[ 16.481238] ACPI: Power Resource [URP1] (off)
[ 16.481265] ACPI: Power Resource [URP2] (off)
[ 16.481294] ACPI: Power Resource [FDDP] (off)
[ 16.481320] ACPI: Power Resource [LPTP] (off)

 16.481329] Linux Plug and Play Support v0.97 (c) Adam Belay
[ 16.481341] pnp: PnP ACPI init
[ 16.481349] ACPI: bus type pnp registered
[ 16.483771] pnp: PnP ACPI: found 11 devices
[ 16.483774] ACPI: ACPI bus type pnp unregistered
[ 16.483779] PnPBIOS: Disabled by ACPI PNP
[ 16.483844] PCI: Using ACPI for IRQ routing
[ 16.483848] PCI: If a device doesn't work, try "pci=routeirq". If it
helps, post a report
[ 16.486761] NET: Registered protocol family 8
[ 16.486764] NET: Registered protocol family 20
[ 16.486848] pnp: 00:01: iomem range 0xfee00000-0xfee00fff could not
be reserved
[ 16.487367] Time: tsc clocksource has been installed.
[ 16.517180] PCI: Bridge: 0000:00:01.0
[ 16.517182] IO window: disabled.
[ 16.517188] MEM window: cdd00000-cfefffff
[ 16.517192] PREFETCH window: c5a00000-cdbfffff

Do you know maybe the reason of the PCI interruption?

Thanks in advance

tom

Robert Di Gioia schreef:
> Your question #22178 on openoffice.org in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/openoffice.org/+question/22178
>
> Status: Open => Needs information
>
> Robert Di Gioia requested for more information:
> Hi.
>
> You might want to see if the system is recognizing the adapter at all.
> To do this, type the following command. It will ask for your password,
> type it in and press enter even though you won't see anything while
> typing the password, it is ok.
>
> sudo lshw -C network | less
>
> You can also look through syslog and see if there are any error messages
> related to the edimax card while booting. There are many ways to do
> this, one way to do this is to type
>
> dmesg | less
>
> and then while in less type /ireless
>
> yes, a slash, followed by wireless without the w :)
>
> Good luck, and hope it helps
>
>

Robert Di Gioia (digioiar) said : #3

Hi Tom,

Can't say for sure about the reason for PCI interruption, but on my system, I had to add pci=routeirq to have the system see all of my PCI bridges. This may be impacting your network card if it is a PCI card.

If you want to try this, here is what you do.

cd /boot/grub
sudo cp menu.lst menu.lst.bak
sudo gedit menu.lst

once in gedit, find the first line that starts with the word kernel
It should be a ways down in the file, in mine its line 132, but yours may or may not be the same. It will be a few lines past a line that says ## ## End Default Options ##

go to the end of the line that begins with kernel (which may actually be on the next line), add a space, and then type pci=routeirq

save the file, and reboot, and see if it helps.

if it does help, you will want to make the change permanent. to do so, edit the same file (/boot/grub/menu.lst). this time look for a line that starts with
# kopt=
and to the end of it add a space and pci=routeirq

This will make it so the option doesn't disappear with the next kernel update.

Hope this helps.

Can you help with this problem?

Provide an answer of your own, or ask tomw for more information if necessary.

To post a message you must log in.