Wireless keeps disconnecting on HP G7000

Asked by Camilla Heggem on 2010-08-31

Hi. I've been having this problem for a good while now, and I would really love to find a solution to this, as it is very inconvenient for me.

Sometimes, at random, the wireless connection disconnects, and even though I can see the list of available networks, using the right password and turn off and on the wireless card, it refuses to reconnect. I need to restart the computer to make it reconnect.

It usually happens often when it first starts. For example, today and yesterday evening, it has been turning off after a very short time every time I restart the computer.

I'm running Ubuntu 10.04 LTS - the Lucid Lynx, and have never installed any form of wireless manager. Just the one that came with 10.04. I'm using a HP G7000 laptop.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu wireless-tools Edit question
Assignee:
No assignee Edit question
Last query:
2010-08-31
Last reply:
2010-09-01

Hi,

Please first connect your network card to the wireless router using an ethernet cable (also known as a LAN cable).

In order to gather essential troubleshooting information about your wireless card, please follow this procedure, RIGHT AFTER the disconnect issue occurs in the near future:

Step 1: Open Terminal from "Applications->Accessories->Terminal"

Step 2: Please copy-paste the following command from the https://answers.launchpad.net/ubuntu website in Firefox into the Linux Terminal. Do NOT copy-paste from the Email message into the Terminal, as that will only copy PART of the command. The command STARTS with the word sudo and ENDS with the word restart. So please copy-paste the ENTIRE command below from Firefox into a Terminal, press <enter>, then enter password when sudo asks for password, then press enter again.

Tip: If you have a wheel mouse or 3 button mouse you do not need to type commands into the Terminal. Highlight the command written on the page. Move your cursor anywhere in the Terminal and press the wheel or middle button. Automatic Copy and paste! No spelling mistakes! No Typos! No other errors!

sudo apt-get update; sudo apt-get install hwinfo grep; sudo lshw -C network; rfkill list; sudo iwlist scanning; cat /etc/network/interfaces; cat /etc/lsb-release; lspci -nn; lsusb; sudo lshw -short; uname -a; dmesg | egrep 'acx|at76|ath|b43|bcm|CX|eth|ipw|irmware|isl|lbtf|ndiswrapper|NPE|ound|prism|rtl|rt2|rt3|witch|wl'; iwconfig; grep b43 /etc/modprobe.d/*; grep wl /etc/modprobe.d/*; sudo hwinfo --netcard ; sudo lsmod; sudo /etc/init.d/networking restart

Step 3: Please post results (copy/paste terminal output) on this thread. The troubleshooters here need to see the full Terminal output from running the above command RIGHT AFTER the wireless disconnect issue occurs.

Regards,

Mark

Camilla Heggem (milladamen) said : #2

I wasn't sure where I should stop copy/pasting, so here's the whole thing, with installation and all.

Hit http://archive.canonical.com karmic Release.gpg
Ign http://archive.canonical.com/ubuntu/ karmic/partner Translation-en_US
Get:1 http://security.ubuntu.com lucid-security Release.gpg [189B]
Ign http://security.ubuntu.com/ubuntu/ lucid-security/main Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ lucid-security/restricted Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ lucid-security/universe Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ lucid-security/multiverse Translation-en_US
Hit http://archive.canonical.com karmic Release
Hit http://no.archive.ubuntu.com lucid Release.gpg
Ign http://no.archive.ubuntu.com/ubuntu/ lucid/main Translation-en_US
Get:2 http://security.ubuntu.com lucid-security Release [38.5kB]
Ign http://no.archive.ubuntu.com/ubuntu/ lucid/restricted Translation-en_US
Ign http://no.archive.ubuntu.com/ubuntu/ lucid/universe Translation-en_US
Ign http://no.archive.ubuntu.com/ubuntu/ lucid/multiverse Translation-en_US
Get:3 http://no.archive.ubuntu.com lucid-updates Release.gpg [189B]
Ign http://no.archive.ubuntu.com/ubuntu/ lucid-updates/main Translation-en_US
Ign http://no.archive.ubuntu.com/ubuntu/ lucid-updates/restricted Translation-en_US
Ign http://no.archive.ubuntu.com/ubuntu/ lucid-updates/universe Translation-en_US
Ign http://no.archive.ubuntu.com/ubuntu/ lucid-updates/multiverse Translation-en_US
Hit http://no.archive.ubuntu.com lucid Release
Get:4 http://no.archive.ubuntu.com lucid-updates Release [44.7kB]
Hit http://archive.canonical.com karmic/partner Packages
Hit http://no.archive.ubuntu.com lucid/main Packages
Hit http://no.archive.ubuntu.com lucid/restricted Packages
Hit http://no.archive.ubuntu.com lucid/universe Packages
Hit http://no.archive.ubuntu.com lucid/multiverse Packages
Hit http://archive.canonical.com karmic/partner Sources
Get:5 http://security.ubuntu.com lucid-security/main Packages [66.9kB]
Get:6 http://no.archive.ubuntu.com lucid-updates/main Packages [291kB]
Get:7 http://security.ubuntu.com lucid-security/restricted Packages [14B]
Get:8 http://security.ubuntu.com lucid-security/universe Packages [33.4kB]
Get:9 http://security.ubuntu.com lucid-security/multiverse Packages [1,998B]
Hit http://linux.dropbox.com lucid Release.gpg
Get:10 http://no.archive.ubuntu.com lucid-updates/restricted Packages [3,252B]
Get:11 http://no.archive.ubuntu.com lucid-updates/universe Packages [106kB]
Get:12 http://no.archive.ubuntu.com lucid-updates/multiverse Packages [3,771B]
Ign http://linux.dropbox.com/ubuntu/ lucid/main Translation-en_US
Hit http://linux.dropbox.com lucid Release
Hit http://linux.dropbox.com lucid/main Packages
Fetched 589kB in 1s (367kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
grep is already the newest version.
The following extra packages will be installed:
  libhd16
The following NEW packages will be installed:
  hwinfo libhd16
0 upgraded, 2 newly installed, 0 to remove and 14 not upgraded.
Need to get 744kB of archives.
After this operation, 2,060kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://no.archive.ubuntu.com/ubuntu/ lucid/universe libhd16 16.0-2 [698kB]
Get:2 http://no.archive.ubuntu.com/ubuntu/ lucid/universe hwinfo 16.0-2 [46.1kB]
Fetched 744kB in 0s (1,160kB/s)
Selecting previously deselected package libhd16.
(Reading database ... 206807 files and directories currently installed.)
Unpacking libhd16 (from .../libhd16_16.0-2_i386.deb) ...
Selecting previously deselected package hwinfo.
Unpacking hwinfo (from .../hwinfo_16.0-2_i386.deb) ...
Processing triggers for man-db ...
Setting up libhd16 (16.0-2) ...

Setting up hwinfo (16.0-2) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
  *-network
       description: Network controller
       product: BCM4311 802.11b/g WLAN
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 02
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=b43-pci-bridge latency=0
       resources: irq:16 memory:51300000-51303fff
  *-network
       description: Ethernet interface
       product: RTL-8139/8139C/8139C+
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 1
       bus info: pci@0000:02:01.0
       logical name: eth0
       version: 10
       serial: 00:1b:38:87:2e:b0
       size: 100MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=full ip=192.168.1.4 latency=64 link=yes maxlatency=64 mingnt=32 multicast=yes port=MII speed=100MB/s
       resources: irq:16 ioport:1000(size=256) memory:51200000-512000ff
  *-network
       description: Wireless interface
       physical id: 1
       logical name: wlan0
       serial: 00:1a:73:ae:1c:df
       capabilities: ethernet physical wireless
       configuration: broadcast=yes multicast=yes wireless=IEEE 802.11bg
0: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wlan0 No scan results

auto lo
iface lo inet loopback

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04.1 LTS"
00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 03)
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 03)
00:02.1 Display controller [0380]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a03] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 03)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 [8086:283f] (rev 03)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 [8086:2830] (rev 03)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 [8086:2831] (rev 03)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 [8086:2832] (rev 03)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 [8086:2836] (rev 03)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev f3)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller [8086:2815] (rev 03)
00:1f.1 IDE interface [0101]: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller [8086:2850] (rev 03)
00:1f.2 SATA controller [0106]: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller [8086:2829] (rev 03)
00:1f.3 SMBus [0c05]: Intel Corporation 82801H (ICH8 Family) SMBus Controller [8086:283e] (rev 03)
01:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 02)
02:01.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ [10ec:8139] (rev 10)
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
H/W path Device Class Description
==========================================================
                                   system HP G7000 Notebook PC
/0 bus 30D9
/0/0 memory 1MiB BIOS
/0/e processor Intel(R) Celeron(R) CPU
/0/e/f memory 1MiB L2 cache
/0/e/11 memory 32KiB L1 cache
/0/10 memory 32KiB L1 cache
/0/12 memory 1GiB System Memory
/0/12/0 memory 512MiB SODIMM DDR2 Synchronous 53
/0/12/1 memory 512MiB SODIMM DDR2 Synchronous 53
/0/100 bridge Mobile PM965/GM965/GL960 Memory C
/0/100/2 display Mobile GM965/GL960 Integrated Gra
/0/100/2.1 display Mobile GM965/GL960 Integrated Gra
/0/100/1b multimedia 82801H (ICH8 Family) HD Audio Con
/0/100/1c bridge 82801H (ICH8 Family) PCI Express
/0/100/1c/0 network BCM4311 802.11b/g WLAN
/0/100/1d bus 82801H (ICH8 Family) USB UHCI Con
/0/100/1d.1 bus 82801H (ICH8 Family) USB UHCI Con
/0/100/1d.2 bus 82801H (ICH8 Family) USB UHCI Con
/0/100/1d.7 bus 82801H (ICH8 Family) USB2 EHCI Co
/0/100/1e bridge 82801 Mobile PCI Bridge
/0/100/1e/1 eth0 network RTL-8139/8139C/8139C+
/0/100/1f bridge 82801HEM (ICH8M) LPC Interface Co
/0/100/1f.1 scsi0 storage 82801HBM/HEM (ICH8M/ICH8M-E) IDE
/0/100/1f.1/0.0.0 /dev/cdrom disk DVD RW AD-7560A
/0/100/1f.2 scsi2 storage 82801HBM/HEM (ICH8M/ICH8M-E) SATA
/0/100/1f.2/0.0.0 /dev/sda disk 120GB FUJITSU MHW2120B
/0/100/1f.2/0.0.0/1 /dev/sda1 volume 108GiB EXT4 volume
/0/100/1f.2/0.0.0/2 /dev/sda2 volume 2910MiB Extended partition
/0/100/1f.2/0.0.0/2/5 /dev/sda5 volume 2910MiB Linux swap / Solaris part
/0/100/1f.3 bus 82801H (ICH8 Family) SMBus Contro
/1 wlan0 network Wireless interface
Linux shiny 2.6.32-24-generic #41-Ubuntu SMP Thu Aug 19 01:12:52 UTC 2010 i686 GNU/Linux
[ 0.000000] found SMP MP-table at [c00fe270] fe270
[ 0.024934] SMP alternatives: switching to UP code
[ 0.306850] [Firmware Bug]: ACPI: ACPI brightness control misses _BQC function
[ 0.308366] ACPI: No dock devices found.
[ 0.324019] Switching to clocksource tsc
[ 0.397571] pnp: PnP ACPI: found 9 devices
[ 0.468842] Firmware did not grant requested _OSC control
[ 0.468880] Firmware did not grant requested _OSC control
[ 0.584388] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input1
[ 0.584432] ACPI: Lid Switch [LID0]
[ 0.592508] Switching to clocksource hpet
[ 0.829990] hub 1-0:1.0: USB hub found
[ 0.830296] hub 2-0:1.0: USB hub found
[ 0.830543] hub 3-0:1.0: USB hub found
[ 0.830797] hub 4-0:1.0: USB hub found
[ 0.865250] device-mapper: multipath: version 1.1.0 loaded
[ 0.865253] device-mapper: multipath round-robin: version 1.0.0 loaded
[ 0.867344] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 1.142816] isapnp: No Plug & Play device found
[ 1.474275] b43-pci-bridge 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 1.474287] b43-pci-bridge 0000:01:00.0: setting latency timer to 64
[ 1.483306] eth0: RealTek RTL8139 at 0x1000, 00:1b:38:87:2e:b0, IRQ 16
[ 1.532192] ssb: Sonics Silicon Backplane found on PCI device 0000:01:00.0
[ 22.739617] lp: driver loaded but no devices found
[ 23.121678] ndiswrapper version 1.55 loaded (smp=yes, preempt=no)
[ 23.306706] usbcore: registered new interface driver ndiswrapper
[ 23.361415] b43-phy0: Broadcom 4311 WLAN found (core revision 13)
[ 23.522669] Registered led device: b43-phy0::tx
[ 23.522686] Registered led device: b43-phy0::rx
[ 23.522702] Registered led device: b43-phy0::radio
[ 23.522773] Broadcom 43xx driver loaded [ Features: PL, Firmware-ID: FW13 ]
[ 24.176085] b43 ssb0:0: firmware: requesting b43/ucode13.fw
[ 24.203324] b43 ssb0:0: firmware: requesting b43/b0g0initvals13.fw
[ 24.352117] b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
[ 24.543226] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 24.547189] eth0: link down
[ 24.547451] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 24.695346] [Firmware Bug]: ACPI: ACPI brightness control misses _BQC function
[ 24.912883] Console: switching to colour frame buffer device 160x50
[ 25.461418] cfg80211: Found new beacon on frequency: 2472 MHz (Ch 13) on phy0
[ 39.564392] wlan0: deauthenticating from 00:22:07:05:f2:84 by local choice (reason=3)
[ 39.566069] wlan0: direct probe to AP 00:22:07:05:f2:84 (try 1)
[ 39.764056] wlan0: direct probe to AP 00:22:07:05:f2:84 (try 2)
[ 39.766331] wlan0: direct probe responded
[ 39.766338] wlan0: authenticate with AP 00:22:07:05:f2:84 (try 1)
[ 39.768148] wlan0: authenticated
[ 39.768293] wlan0: associate with AP 00:22:07:05:f2:84 (try 1)
[ 39.770694] wlan0: RX AssocResp from 00:22:07:05:f2:84 (capab=0x411 status=0 aid=2)
[ 39.770698] wlan0: associated
[ 39.771369] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 49.812026] wlan0: no IPv6 routers present
[12453.458487] wlan0: direct probe to AP 00:22:07:05:f2:84 (try 1)
[12453.460727] wlan0: direct probe responded
[12453.460732] wlan0: authenticate with AP 00:22:07:05:f2:84 (try 1)
[12453.462431] wlan0: authenticated
[12453.462455] wlan0: associate with AP 00:22:07:05:f2:84 (try 1)
[12453.465038] wlan0: RX AssocResp from 00:22:07:05:f2:84 (capab=0x411 status=0 aid=1)
[12453.465043] wlan0: associated
[44733.458494] wlan0: direct probe to AP 00:22:07:05:f2:84 (try 1)
[44733.656044] wlan0: direct probe to AP 00:22:07:05:f2:84 (try 2)
[44733.856036] wlan0: direct probe to AP 00:22:07:05:f2:84 (try 3)
[44734.056279] wlan0: direct probe to AP 00:22:07:05:f2:84 timed out
[44744.680190] wlan0: direct probe to AP 00:22:07:05:f2:84 (try 1)
[44744.682506] wlan0: direct probe responded
[44744.682513] wlan0: authenticate with AP 00:22:07:05:f2:84 (try 1)
[44744.684171] wlan0: authenticated
[44744.684200] wlan0: associate with AP 00:22:07:05:f2:84 (try 1)
[44744.686730] wlan0: RX AssocResp from 00:22:07:05:f2:84 (capab=0x411 status=0 aid=1)
[44744.686734] wlan0: associated
[47152.159798] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
[50820.089769] b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000800, 0x00000000, 0x00000000, 0x00000000, 0x00000000
[50820.089778] b43-phy0 ERROR: This device does not support DMA on your system. Please use PIO instead.
[50820.089781] b43-phy0: Controller RESET (DMA error) ...
[50820.349753] b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
[50820.448719] b43-phy0: Controller restarted
[51007.940167] eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
[51007.940408] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[51018.724029] eth0: no IPv6 routers present
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:off/any
          Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
          Tx-Power=20 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Power Management:off

/etc/modprobe.d/blacklist.conf:# replaced by b43 and ssb.
/etc/modprobe.d/blacklist-watchdog.conf:blacklist twl4030_wdt
/etc/modprobe.d/ndiswrapper:alias wlan0 ndiswrapper
22: PCI 100.0: 0282 WLAN controller
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_14e4_4311
  Unique ID: y9sn.wZtoJ4c7zyA
  Parent ID: z8Q3.yjCEx5JbDxB
  SysFS ID: /devices/pci0000:00/0000:00:1c.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: network
  Model: "Hewlett-Packard Company BCM4311 802.11b/g Wireless LAN Controller"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x4311 "BCM4311 802.11b/g WLAN"
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x1375 "BCM4311 802.11b/g Wireless LAN Controller"
  Revision: 0x02
  Driver: "b43-pci-bridge"
  Driver Modules: "ssb"
  Device File: wlan0
  Features: WLAN
  Memory Range: 0x51300000-0x51303fff (rw,non-prefetchable)
  IRQ: 16 (16637576 events)
  HW Address: 00:1a:73:ae:1c:df
  Link detected: no
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 2.484
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "pci:v000014E4d00004311sv0000103Csd00001375bc02sc80i00"
  Driver Info #0:
    Driver Status: ssb is active
    Driver Activation Cmd: "modprobe ssb"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #12 (PCI bridge)

23: PCI 201.0: 0200 Ethernet controller
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_10ec_8139
  Unique ID: rBUF.9PjSIsrT6xB
  Parent ID: 6NW+.o1FfZoLxn+0
  SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:02:01.0
  SysFS BusID: 0000:02:01.0
  Hardware Class: network
  Model: "Hewlett-Packard Company Presario C700"
  Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
  Device: pci 0x8139 "RTL-8139/8139C/8139C+"
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x30d9 "Presario C700"
  Revision: 0x10
  Driver: "8139too"
  Driver Modules: "8139too"
  Device File: eth0
  I/O Ports: 0x1000-0x1fff (rw)
  Memory Range: 0x51200000-0x512000ff (rw,non-prefetchable)
  IRQ: 16 (16637576 events)
  HW Address: 00:1b:38:87:2e:b0
  Link detected: yes
  Module Alias: "pci:v000010ECd00008139sv0000103Csd000030D9bc02sc00i00"
  Driver Info #0:
    Driver Status: 8139too is active
    Driver Activation Cmd: "modprobe 8139too"
  Driver Info #1:
    Driver Status: 8139cp is active
    Driver Activation Cmd: "modprobe 8139cp"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #17 (PCI bridge)
Module Size Used by
binfmt_misc 6587 1
snd_hda_codec_conexant 22641 1
fbcon 35102 71
tileblit 2031 1 fbcon
font 7557 1 fbcon
bitblit 4707 1 fbcon
softcursor 1189 1 bitblit
vga16fb 11385 0
vgastate 8961 1 vga16fb
ppdev 5259 0
joydev 8708 0
snd_hda_intel 21941 3
snd_hda_codec 74201 2 snd_hda_codec_conexant,snd_hda_intel
snd_hwdep 5412 1 snd_hda_codec
snd_pcm_oss 35308 0
snd_mixer_oss 13746 1 snd_pcm_oss
snd_pcm 70662 4 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_dummy 1338 0
snd_seq_oss 26726 0
snd_seq_midi 4557 0
snd_rawmidi 19056 1 snd_seq_midi
arc4 1153 2
snd_seq_midi_event 6003 2 snd_seq_oss,snd_seq_midi
snd_seq 47263 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
i915 285076 3
drm_kms_helper 29297 1 i915
snd_timer 19098 2 snd_pcm,snd_seq
snd_seq_device 5700 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
b43 163523 0
drm 162409 4 i915,drm_kms_helper
mac80211 205146 1 b43
snd 54148 17 snd_hda_codec_conexant,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
intel_agp 24119 2 i915
cfg80211 126517 2 b43,mac80211
soundcore 6620 1 snd
led_class 2864 1 b43
i2c_algo_bit 5028 1 i915
agpgart 31724 2 drm,intel_agp
snd_page_alloc 7076 2 snd_hda_intel,snd_pcm
psmouse 63245 0
serio_raw 3978 0
ndiswrapper 184677 0
video 17375 1 i915
output 1871 1 video
lp 7028 0
parport 32635 2 ppdev,lp
8139too 18545 0
8139cp 16186 0
mii 4381 2 8139too,8139cp
ahci 32200 2
ssb 38671 1 b43
 * Reconfiguring network interfaces... Ignoring unknown interface eth0=eth0.

Your Terminal output shows the following serious issues:

1)

Hit http://archive.canonical.com karmic Release.gpg
Ign http://archive.canonical.com/ubuntu/ karmic/partner Translation-en_US
Get:1 http://security.ubuntu.com lucid-security Release.gpg [189B]
Ign http://security.ubuntu.com/ubuntu/ lucid-security/main Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ lucid-security/restricted Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ lucid-security/universe Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ lucid-security/multiverse Translation-en_US
Hit http://archive.canonical.com karmic Release

So your /etc/apt/sources.list file contains a mix of karmic and lucid repositories. This will cause serious problems. Repositories from different releases of Ubuntu should NEVER be mixed in the /etc/apt/sources.list file.

2) The following error keeps occurring:

wlan0: deauthenticating from 00:22:07:05:f2:84 by local choice (reason=3)

This is probably due to the fact that your wireless driver (b43 driver) is not working correctly. I think this is due to issue 3 -> 2 different wireless drivers are active at the same time on your PC (b43 driver and ndiswrapper driver)

3) both b43 and ndiswrapper drivers are active at the same time, which will cause disconnects and instability

The following Terminal output confirms this:

Broadcom 43xx driver loaded [ Features: PL, Firmware-ID: FW13 ]

[ 23.121678] ndiswrapper version 1.55 loaded (smp=yes, preempt=no)

b43 163523 0

ndiswrapper 184677 0

/etc/modprobe.d/ndiswrapper:alias wlan0 ndiswrapper

There are too many configuration problems on your PC.

To solve it, I recommend performing a backup of all your personal data. Then perform a clean install of Ubuntu 10.04 from a LiveCD session, overwriting the contents of the / (root) partition, but not overwriting the /home partition.

AFTER performing a clean install, only the following procedure is required to get wireless working:

Do NOT install ndiswrapper after the clean install, as it will cause conflicts with the b43 wireless driver.

Step 1: Open Terminal from "Applications->Accessories->Terminal"

Step 2: Please copy-paste the following 2 commands into the Linux Terminal. Press <enter> after each command.

sudo aptitude update
sudo aptitude install b43-fwcutter

Step 3: Reboot and retest wireless.

Can you help with this problem?

Provide an answer of your own, or ask Camilla Heggem for more information if necessary.

To post a message you must log in.