.exe installation program hangs up when using wine

Asked by kittenlover

I'm trying to install an .exe file using wine. Installation of the program starts but then hangs the computer up. Any suggestions or solutions?

Question information

English Edit question
Ubuntu wine Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
kittenlover (kittencatlover24) said :

I'm trying to install ITunes. It gets to the third screen and the system stops. Can ANYONE help????

Revision history for this message
kittenlover (kittencatlover24) said :

I've also tried installing QuickTime and it does the same thing. Could something be missing in wine?

Revision history for this message
kittenlover (kittencatlover24) said :

In a terminal, I typed "wine iTunesSetup.exe". It again went through two screens and when it got to the third this is the message that appeared in the terminal -
err: ntdll: RtlpWaitForCriticalSection Section 0x7e5244c0 "xlldrv_main. c: X11DRV_C rit Section" wait timed out in thread 0017, blocked by 0020, retrying
fixme: exec: SHELL_execute flags ignored: 0x00000500.
Am I missing a driver and if so, what do I need to install? PLEASE HELP!!!!!

Revision history for this message
evil_ogel (evil-ogel) said :

Do you people have windows partitions?

Try coping all the files from your System32 folder on your windows partition, to Wines version of System32!
These include the files, and DLLs that Windows uses to run it's native programs. Wine is pretty much a clone of windows, in they way the two run applications; wine only slaps them into linux's GUI.

Do you have the most popular portable music player on the face of the world; the iPod?
Despite iTunes's ultra-friendly user interface, Gtkpod can sync your photos, music, and videos to your iPod, without the use of Wine. Apple did not create the iPod with linux in mind, so unfortunately there is not many easy-way-outs for this.

My own opinion about Wine? I find it only good for running pre-installed applications you use with your keychain drive; applications that don't need registry entries more specifically.

With great concern,


Revision history for this message
kittenlover (kittencatlover24) said :

What do you mean by windows partitions? I'm running Linux if that means anything. I did find Gtkpod and it works!!!!! but I would still like to get wine working.

Revision history for this message
evil_ogel (evil-ogel) said :

Did you migrate from Windows to Ubuntu? When you installed it did you split your HDD in two, so you can still boot to either one? Or do you have another windows computer laying abouts? You can migrate the files from the C:/ System 32, to WINE's system32. This solved my problem with installing Ensemble Studios' Age of Mythology. But like I say, WINE doesn't replace Windows. It only supplements it.

There are many alternatives to Windows programs. For example the gstreamer plug-ins can allow to play not only Mp3, Mpeg and that stuff, but you can also install a package made for playing quicktime native files.

It does seem that programs that don't need Windows registry entries seem to run better then those that do.

I've used WINE before, I've switched to great, open-source alternatives.

Revision history for this message
kittenlover (kittencatlover24) said :

No, I didn't migrate from Windows. I bought the computer with a Gos system then installed Ubuntu. So I don't think I have access to any original windows files. I am having problems with the Gtkpod - when I try to transfer some songs from an older ipod to the 4th generation I bought this error occurred - "The GStreamer plugins to decode "MP3" files cannot be found". I went into the package manager and installed all the GStreamer files I had and it still won't work. Any clues?

Revision history for this message
evil_ogel (evil-ogel) said :

I am having a similar problem. I think the 4th generation iPod Nano is simply too new for anything but iTunes. In fact I couldn't even get it too work with the iPod Dock I bought. I see your point in using WINE. iTunes will first activate the iPod between a Windows filesystem, or a Mac OS filesystem. Gtkpod claims to do the same thing.
At the moment, I recommend continuing to use your older iPod. Gtkpod will soon likely come out with an update for the newer iPod 4th Generation. I'll look into the iTunes thing.

Revision history for this message
kittenlover (kittencatlover24) said :

In reading my error message through wine, do you think I'm missing a driver. If so, any idea what one I need? Also, what about the GStreamer plugins message I'm getting though Gtkpod?

Revision history for this message
evil_ogel (evil-ogel) said :

I do not believe so. I tried to install iTunes through WINE my self. During the install I unchecked the question asking if iTunes could enable autoplay on it's own. Then it worked fine. I was even able to get quicktime to work.
As for Gtkpod, the iPod Nano 4th Generation simply doesn't work with the older software.

Revision history for this message
kittenlover (kittencatlover24) said :

I only got to the third screen on trying to install iTunes, the one where it starts to install ITunes and QuickTime then the computer freezes. If I try to move the mouse, it will take 10 seconds but it will move. However, if I click on something, it still won't respond. What can I do?

Revision history for this message
Dan Kegel (dank) said :

The system should not stop. If it really does, you have a kernel problem (possibly a
mismatched nvidia driver).
The screen may go black during itunes installation; that's
The installation of itunes 8.0.x fails still; that's
See http://appdb.winehq.org/objectManager.php?sClass=application&iId=1347 for more info.

You may want to try an older version of itunes. Best is to use a native linux app instead, unless you need to access the itunes store.

No version of itunes currently syncs with ipods properly on wine, as far as I know.

Revision history for this message
Steve Dodier-Lazaro (sidi) said :


You should *never* take a DLL file from Windows and put it under Wine ! Wine implements functions with GNU/Linux code so that it works under Linux. If you replace a wine system DLL by a windows one, you may aswell completely break wine and prevent anything to run. Only do it for DLLs that were not already installed in Wine, for exemple Visual C++ or DirectX dlls !

Revision history for this message
cogadh (cogadh) said :

I'm afraid you are quite wrong about that. Overidden DLLs are "running" within Wine's implementation of the Windows API, not within Linux (technically speaking). Many of the DLLs built into Wine are not complete and there are only a few DLLs in Wine that should never be overridden: kernel32.dll, gdi32.dll, user32.dll, and ntdll.dll. Any other DLL can be overridden, if required, though they may not necessarily work better than Wine's built-in DLLs. From the Wine user guide:

Revision history for this message
Steve Dodier-Lazaro (sidi) said :

My bad, that's not what i'd been told ! Sorry then :)

Revision history for this message
Dan Kegel (dank) said :

See also
about where to safely get missing redistributable runtime libraries.

Can you help with this problem?

Provide an answer of your own, or ask kittenlover for more information if necessary.

To post a message you must log in.