No text in wine

Asked by John Brooks

When I try to run ANYTHING in wine (A Windows Compatibility layer), there is no text whatsoever. The only text there would be would be text in grayed out buttons. I am using Ubuntu 8.10 Intrepid. wine works on my other computer with no problem, and I have tried copying the wine directory from there, but nothing has worked.

Here is an image of the wine configuration with no text:

Question information

English Edit question
Ubuntu wine Edit question
No assignee Edit question
Solved by:
Juan Quiceno
Last query:
Last reply:
Revision history for this message
Matt Jones (workhorsy) said :

I'm not sure if this is the problem. But try installing the Microsoft fonts with this command:

sudo apt-get install msttcorefonts

Or install "msttcorefonts" from synaptic.

Did that work?

Revision history for this message
marcobra (Marco Braida) (marcobra) said :

Please install msttcorefonts

Using System → Administration → Software sources [Ubuntu software] please enable the Universe the repository.

Then open a Terminal from the menu Applications → Accessories → Terminal and type:

sudo aptitude update
sudo aptitude install cabextract
sudo aptitude install msttcorefonts

give your user password when requested, you don't see nothing when you type it, then press enter.

Hope this helps

Revision history for this message
snares (snaresv6-4) said :

have the same problem. Ubuntu Intrepid wine has no text. msttcorefonts and cabextract installed. taxt flashes on screen when I closed if that is any help. Still troubleshooting.

Revision history for this message
snares (snaresv6-4) said :

had a brainstorm just as I clicked add answer. Seems to be a compiz or nvidia driver problem. Gonna do somemore trouble shooting. When I went into System > Preferences > Appearance and shutoff desktop effects the problem is... lets say minimized. Words are scratched out. It appears to render words multiple time over one another. Once I highlight the text "scatches" go away. In most programs problem is gone. Need to see if it is becuase I switch to the nv driver or if it is becuase I shutoff compiz.

Revision history for this message
Dan Kegel (dank) said :

What graphics card do you have?
This sounds like
Does switching off the restricted driver
( system / administration / hardware drivers / deactivate, click ok, then reboot )
make the problem go away?

Revision history for this message
Juan Quiceno (masterbard1) said :

hi I am having the exact same problem I have an NVidia geforce mx4000 and ubuntu 8.10 I tried disabling the effects and I get to see some of the text but it's all scratchy like it's re-written over. the image posted above is exactly what I get too.

I tried changing the DPI like I read in a different page but all I get is larger scratchy letters :S hope some one can post a working answer for this cause I have tried all I have read and have had no luck.

I tried disabling the nvidia driver but no luck either :(

Revision history for this message
Dan Kegel (dank) said :

Did you try the workaround of turning off XRender in wine?

i.e. create a file foo.reg

[HKEY_CURRENT_USER\Software\Wine\X11 Driver]

and install that key by doing 'wine regedit foo.reg'.

Revision history for this message
Best Juan Quiceno (masterbard1) said :

dude I found the answer. sorry for the double post but here goes thanks to NYbill your answer worked perfectly.

I'll just copy and paste his post hope he doesn't mind :D there is one think I should add make sure in the .txt there are no spaces cause I left a space and it didn't work the first time

(original post)

xmaseed, and i have both run into a problem where our installation of Wine had no words or fonts in the configuration screen.

screen shots here:

if anyone else runs into this problem, here is a fix i googled up. first i installed "msttcorefonts". i'm not sure if this was necessary. but, it doesn't hurt to have them. then create a text file called "settings.txt". insert the following in the text file and save:

[HKEY_CURRENT_USER\Software\Wine\X11 Driver]

then in the terminal (in the folder where you put the txt file) type:
wine regedit settings.txt

and that was it. my wine fonts are now back to normal.

Revision history for this message
John Brooks (frogging101) said :

Thanks Juan Quiceno, that solved my question.

Revision history for this message
striants (siarina-t) said :

Hello from me too. I had the exact same font problem and I followed the proposed solution.
The problem now is that the toolbar icons in Thunderbird portable are not visible (see screenshot: [URL=][IMG][/IMG][/URL] )

any ideas on how to solve this?

Revision history for this message
Steve Dodier-Lazaro (sidi) said :

Hey striants,

You can either use the Ubuntu Thunderbird (it's in the repository, yeh), or install Thunderbird in a different Wine prefix (see their wiki, you need to add something like "WINEPREFIX=.wine2/ wine setup.exe" to setup a program in .wine2 folder instead of .wine, and then add WINEPREFIX=.wine2 before the command to run this program, this prevents from settings for one app to affect the other ones).

Revision history for this message
Steve Dodier-Lazaro (sidi) said :

By the way, about people with low GPU's having troubles with fonts, as Dan and Juan said you could disable XRender (see above). I assume it's text antialiasing features, and some old Nvidia cards using the drivers 96 suffer from a bug related to text antialiasing.

If you have trouble with (the linux one)'s text, it can also be related to these messy drivers, and you should go to OOo's options, and unchex the chexbox that enables text antialiasing (i also heard Opera/Amarok could suffer from it too).

Revision history for this message
striants (siarina-t) said :

Hello SiDI,

thanks for the answers!
Unfortunately I am forced to use Thunderbird Portable through wine as I have to run it from multiple pcs running both windows and linux.
Anyway, my problem appeared after disabling XRender. Before, fonts were garbled. Now, icons disappeared!

thanks again!