Wine problem in Ubuntu 8.10, not in 8.04

Asked by Hans

Hello all!

OK, my question is rather "where and how do I report this bug" than "how can I solve it"
I used an older 16 Bit Windows Program in wine under ubuntu 8.04, updated it to 8.10 and everything was and is great.

I installed ubuntu 8.10 on a different computer, tried various wine-versions and winetricks etc. and always received an error
"Unhandled page fault on read access" when I tried to run this Windows program.

I was able to reproduce the problem on the first computer by starting the ubuntu 8.10 live-system, installing wine and trying to start the program. Right now I am updating the first computer from 8.04, and most likely it should work.

summing up:
It is not limited to one computer (so its no specific hardwareproblem)
Its not limited to one wine-version (so it doesn't seem to be a bug in wine)
It works when updating from 8.04

The problem seems to be in one of the dependencies, but how can I provide that information?
Or is there other information that would be more important?


Question information

English Edit question
Ubuntu wine Edit question
No assignee Edit question
Solved by:
Gord Allott
Last query:
Last reply:
Revision history for this message
Best Gord Allott (gordallott) said :

you can find information about bug reporting here:
if you report the information on there it should be enough, if more is required someone will ask you for it and tell you how to get the information.

Revision history for this message
Scott Ritchie (scottritchie) said :

Was the first system 32 bit or 64 bit? How about the second?

Revision history for this message
Hans (hans-thurner) said :

I only used 32 Bit Systems (aktually 3 where I could produce this error), and the crazy thing is I have one System with ubuntu 8.10 where it is running without error (without doing anything special on purpose). I had installed many packages and updated from 8.04. Doing a "clean update" from a fresh installed 8.04 on the other machine didn't solve the problem as I expected.

I started other Windows applications and they work without error.
I just thought there might be an easy way to find the bug in just comparing the config of the 2 systems, the one is a Laptop (where it works) the other a Desktop though. (but starting the Laptop with the liveCD ubuntu 8.10, installing the stable version of wine and starting my application brought the error)

My problem is solved so far as I installed 8.04 and no updating, and I am happy.

-------- Original-Nachricht --------
> Datum: Thu, 13 Nov 2008 01:48:40 -0000
> Von: Scott Ritchie <email address hidden>
> An: <email address hidden>
> Betreff: Re: [Question #50840]: Wine problem in Ubuntu 8.10, not in 8.04

> Your question #50840 on wine in ubuntu changed:
> Scott Ritchie proposed the following answer:
> Was the first system 32 bit or 64 bit? How about the second?
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> You received this question notification because you are a direct
> subscriber of the question.

Sensationsangebot nur bis 30.11: GMX FreeDSL - Telefonanschluss + DSL
für nur 16,37 Euro/mtl.!*

Revision history for this message
Scott Ritchie (scottritchie) said :

The reason it worked is likely due to some configuration you made within Wine itself - perhaps installing a different program (that in turn provided a Windows DLL you needed), or perhaps some other customization you forgot about.

You could try copying the working ~/.wine from one system to the other.

Revision history for this message
Hans (hans-thurner) said :

I forgot to tell you that copying the .wine folder was one of the first things that i tried out.
But now I tried that again, also including the ~/.winetrickscache folder and it works now, at least on this computer here.

I belive there are still some things strange about this (working out of the box at 8.04 without providing any dll or other stuff at the same wine version) but since I found out that the same error comes now and then in Windows; and independent from that error - converting a database (within that program) brought an error under windows - and worked without a problem in wine.... *confused*, I think it's probably not that easy to fix this.

Thank you,

Revision history for this message
Hans (hans-thurner) said :

I finally found the Mistake.

The Windows-Program requieres an installed Printer-Driver, or else it crashes (no commend on that...) . Wine works just like Windows concerning that Error-Message. I just didn't think that a not installed printer could have any effects.

Anyways, thank you for your replies!

Revision history for this message
Hans (hans-thurner) said :

Thanks Gord Allott, that solved my question.