Possible to include AcceptEx-General.patch in Wine?

Asked by theanalogkid on 2008-08-03

Currently with Wine-1.0.0-ubuntu7 it is impossible to host a game in Warcraft 3, this is a known issue and the patch found at http://bugs.winehq.org/show_bug.cgi?id=9787, will fix the issue. Is it possible to include it in Intrepid's wine package or do I have to wait for it to be included in the upstream version first before it makes it's way into Ubuntu?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu wine Edit question
Assignee:
No assignee Edit question
Last query:
2008-08-03
Last reply:
2008-08-04
Thor K. H. (nitrolinken) said : #1

It's not a good idea to patch this for the Intrepid package, patches need to be checked according to certain standards. The only solution for you would be to get the sources yourself and apply the patch.

Scott Ritchie (scottritchie) said : #2

If the patch gets committed upstream, applies cleanly to 1.0, and doesn't cause regressions then it can go into 1.0.1 or the Ubuntu package. I added it to the list of candidate patches for Intrepid here: https://wiki.ubuntu.com/WineTeam/Contributing

Can you help with this problem?

Provide an answer of your own, or ask theanalogkid for more information if necessary.

To post a message you must log in.