Caps lock won't work in Wine (Ubuntu)

Asked by Gautier Rouleau on 2015-12-29

Hi everyone,

I'm running Ubuntu 15.10 and I'm having a little problem: the caps lock won't work in any windows application.
Here's what I did:
- I ran `winecfg` in a terminal and I went to the "About" section
- I tried typing my name with the caps lock ON in any text area and it wrote all of it in lower-case

I'd like to report a bug about this, it seems to happen with any version of wine; I've tried with v1.6.2, v1.7.52, v1.8 and v1.8-staging.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu wine Edit question
Assignee:
No assignee Edit question
Last query:
2015-12-29
Last reply:
2015-12-29

This question was reopened

http://eab.abime.net/showthread.php?t=63258

Is this for Skyrim?

I found this which says set a different key to toggle running:
https://appdb.winehq.org/objectManager.php?sClass=version&iId=24749

Gautier Rouleau (rolexiss) said : #2

Thanks for answering, but unfortunately it has nothing to do with Skyrim or the other link.

My problem concerns any application running with wine. I even tried with Notepad++ and whatever I'd type (with the Caps Lock ON) would be lowercase.

http://notepadqq.altervista.org/wp/

Notepadqq is a Notepad++-like editor for the Linux desktop.

Install instructions as per:
http://notepadqq.altervista.org/wp/download/

sudo add-apt-repository ppa:notepadqq-team/notepadqq
sudo apt-get update
sudo apt-get install notepadqq

Then use that.

Bit easier...... and cleaner.

Gautier Rouleau (rolexiss) said : #4

Sorry if I'm not explaining clearly but Notepad++ is not the issue here. My problem concerns the wine core.

I'm using PlayOnLinux to install my windows apps but even when I'm just going to the wine configuration panel, I get the same effect.

Gautier Rouleau (rolexiss) said : #5

By the way this is a mistake, my problem is not solved.

I suggest you report a bug.

There are lots of native applications for Ubuntu rather than using WINE. I suggest you explore those first.

If you are using the PPA version then directly contacting the PPA maintainers may give a fix.

Can you help with this problem?

Provide an answer of your own, or ask Gautier Rouleau for more information if necessary.

To post a message you must log in.