Can't play games using external hard drive

Asked by quinones on 2012-09-03

Good morning/afternoon:

I'm a girl that like to play games. I have a 2TB external hard drive that I divided in 3 partition. One for games. I have steam in the external har drive, also Perfect world international, Shaiya and Repulse among other games. I used to play them in Windows 7 from my external hard drive with no problems. Now with Ubuntu, I can't. I have playonlinux and wine, but still can't open the games.

Shaiya- is the only game that runs normal (runs with Aeria) ) have some glitches in the graphics but is not a big deal.

Repulse-open then program close when try to log in (Runs with aeria too)

Steam- it opens but can't play the games like Battle front (open then freeze the computer only can hear the sound), Team fortress 2 (doesn't open), Hitman (error: failed to find steam), Skyrim (message: error in the program or deficienciy in wine), DC online

Perfect world - only opens the launcher, then freeze

Ghost Recon-
Mon Sep 03 00:10:03 2012

Crash in application version: 29980.2562

GRAW2 requires an up to date version of Ageia PhysX and associated DLLs. Please install latest PhysX runtime.

Renderer: threaded
Physics : threaded

Example error with steam/skyrim
Unhandled exception: unimplemented function msvcp90.dll.??0?$basic_ifstream@_WU?$char_traits@_W@std@@@std@@QAE@PB_WHH@Z called in 32-bit code (0x7b839cf2).
Register dump:
 CS:0073 SS:007b DS:007b ES:007b FS:0033 GS:003b
 EIP:7b839cf2 ESP:0033f7a0 EBP:0033f804 EFLAGS:00000287( - -- I S - -P-C)
 EAX:7b826245 EBX:7b894ff4 ECX:00000008 EDX:0033f7c0
 ESI:80000100 EDI:00429ef0
Stack dump:
0x0033f7a0: 0033f824 00000008 0041db3c 80000100
0x0033f7b0: 00000001 00000000 7b839cf2 00000002
0x0033f7c0: 7e5e0340 7e5e3992 00000004 7e606550
0x0033f7d0: 0041db3c 0033f8bc 0033f7ec 00403e52
0x0033f7e0: 00000001 00000000 00137cf0 0033f81c
0x0033f7f0: 00403059 0033fb18 7b839caa 00000000
Backtrace:
=>0 0x7b839cf2 in kernel32 (+0x29cf2) (0x0033f804)
  1 0x7e5e02a8 in msvcp90 (+0x402a7) (0x0033f834)
  2 0x7e5ab825 in msvcp90 (+0xb824) (0x0033fd38)
  3 0x0040a040 in skyrimlauncher (+0xa03f) (0x0033fd38)
  4 0x00412633 in skyrimlauncher (+0x12632) (0x0033fde0)
  5 0x00407acf in skyrimlauncher (+0x7ace) (0x0033fe70)
  6 0x7b859cdc call_process_entry+0xb() in kernel32 (0x0033fe88)
  7 0x7b85af4f in kernel32 (+0x4af4e) (0x0033fec8)
  8 0x7bc71db0 call_thread_func_wrapper+0xb() in ntdll (0x0033fed8)
  9 0x7bc7486d call_thread_func+0x7c() in ntdll (0x0033ffa8)
  10 0x7bc71d8e RtlRaiseException+0x21() in ntdll (0x0033ffc8)
  11 0x7bc49f4e call_dll_entry_point+0x61d() in ntdll (0x0033ffe8)
0x7b839cf2: subl $4,%esp
Modules:
Module Address Debug info Name (75 modules)
PE 400000- 5d2000 Export skyrimlauncher
PE 10000000-10094000 Deferred gameoverlayrenderer
PE 3b400000-3b41e000 Deferred steam_api
ELF 7b800000-7ba15000 Dwarf kernel32<elf>
  \-PE 7b810000-7ba15000 \ kernel32
ELF 7bc00000-7bcc3000 Dwarf ntdll<elf>
  \-PE 7bc10000-7bcc3000 \ ntdll
ELF 7bf00000-7bf04000 Deferred <wine-loader>
ELF 7ded0000-7df04000 Deferred uxtheme<elf>
  \-PE 7dee0000-7df04000 \ uxtheme
ELF 7df04000-7df0a000 Deferred libxfixes.so.3
ELF 7df0a000-7df15000 Deferred libxcursor.so.1
ELF 7df88000-7dfb2000 Deferred libexpat.so.1
ELF 7dfb2000-7dfe6000 Deferred libfontconfig.so.1
ELF 7dfe6000-7dff6000 Deferred libxi.so.6
ELF 7dff6000-7dffa000 Deferred libxcomposite.so.1
ELF 7dffa000-7e003000 Deferred libxrandr.so.2
ELF 7e003000-7e024000 Deferred libxcb.so.1
ELF 7e024000-7e03e000 Deferred libice.so.6
ELF 7e03e000-7e06a000 Deferred libm.so.6
ELF 7e06c000-7e076000 Deferred libxrender.so.1
ELF 7e076000-7e07c000 Deferred libxxf86vm.so.1
ELF 7e07c000-7e080000 Deferred libxinerama.so.1
ELF 7e0e1000-7e0e8000 Deferred libxdmcp.so.6
ELF 7e0e8000-7e0ec000 Deferred libxau.so.6
ELF 7e0ec000-7e0f2000 Deferred libuuid.so.1
ELF 7e0f2000-7e226000 Deferred libx11.so.6
ELF 7e226000-7e238000 Deferred libxext.so.6
ELF 7e238000-7e241000 Deferred libsm.so.6
ELF 7e241000-7e2d4000 Deferred winex11<elf>
  \-PE 7e250000-7e2d4000 \ winex11
ELF 7e2d4000-7e2ea000 Deferred libz.so.1
ELF 7e2ea000-7e384000 Deferred libfreetype.so.6
ELF 7e384000-7e3a6000 Deferred imm32<elf>
  \-PE 7e390000-7e3a6000 \ imm32
ELF 7e3a6000-7e3ce000 Deferred msacm32<elf>
  \-PE 7e3b0000-7e3ce000 \ msacm32
ELF 7e3ce000-7e47b000 Deferred winmm<elf>
  \-PE 7e3e0000-7e47b000 \ winmm
ELF 7e47b000-7e4be000 Deferred dsound<elf>
  \-PE 7e480000-7e4be000 \ dsound
ELF 7e4be000-7e4ed000 Deferred msvcr90<elf>
  \-PE 7e4d0000-7e4ed000 \ msvcr90
ELF 7e4ed000-7e57a000 Deferred msvcrt<elf>
  \-PE 7e500000-7e57a000 \ msvcrt
ELF 7e57a000-7e65f000 Dwarf msvcp90<elf>
  \-PE 7e5a0000-7e65f000 \ msvcp90
ELF 7e65f000-7e6d4000 Deferred rpcrt4<elf>
  \-PE 7e670000-7e6d4000 \ rpcrt4
ELF 7e6d4000-7e7dc000 Deferred ole32<elf>
  \-PE 7e6f0000-7e7dc000 \ ole32
ELF 7e7dc000-7e8d4000 Deferred comctl32<elf>
  \-PE 7e7e0000-7e8d4000 \ comctl32
ELF 7e8d4000-7e8ed000 Deferred version<elf>
  \-PE 7e8e0000-7e8ed000 \ version
ELF 7e8ed000-7e9aa000 Deferred gdi32<elf>
  \-PE 7e900000-7e9aa000 \ gdi32
ELF 7e9aa000-7eaea000 Deferred user32<elf>
  \-PE 7e9c0000-7eaea000 \ user32
ELF 7eaea000-7eb54000 Deferred shlwapi<elf>
  \-PE 7eb00000-7eb54000 \ shlwapi
ELF 7eb54000-7ed65000 Deferred shell32<elf>
  \-PE 7eb60000-7ed65000 \ shell32
ELF 7ed65000-7edc5000 Deferred advapi32<elf>
  \-PE 7ed70000-7edc5000 \ advapi32
ELF 7edc5000-7eddf000 Deferred libnsl.so.1
ELF 7eddf000-7ede8000 Deferred libnss_compat.so.2
ELF b73c1000-b73ce000 Deferred libnss_files.so.2
ELF b73cf000-b73d4000 Deferred libdl.so.2
ELF b73d4000-b7579000 Deferred libc.so.6
ELF b757a000-b7595000 Deferred libpthread.so.0
ELF b759f000-b75ab000 Deferred libnss_nis.so.2
ELF b75ab000-b76ed000 Dwarf libwine.so.1
ELF b76ef000-b7711000 Deferred ld-linux.so.2
ELF b7711000-b7712000 Deferred [vdso].so
Threads:
process tid prio (all id:s are in hex)
0000000e services.exe
 0000001a 0
 00000028 0
 0000001f 0
 00000010 0
 0000000f 0
0000001c winedevice.exe
 00000027 0
 00000021 0
 0000001e 0
 0000001d 0
00000022 explorer.exe
 00000023 0
00000024 plugplay.exe
 0000002a 0
 00000026 0
 00000025 0
0000002b Steam.exe
 00000051 0
 00000058 1
 00000067 1
 00000066 1
 00000053 0
 00000052 0
 0000004f 0
 0000004e 0
 0000004c 0
 0000004b 1
 0000004a 1
 00000049 0
 00000048 0
 0000001b 0
 00000017 0
 00000018 0
 00000009 0
 0000003b 0
 00000015 0
 00000029 0
 00000011 0
 00000012 0
 00000019 0
 00000014 0
 00000013 0
 0000003a 0
 00000039 0
 00000038 0
 00000037 0
 00000035 0
 00000036 0
 0000002f 0
 0000000d 0
 0000000b 0
 00000047 0
 00000046 0
 00000045 0
 00000044 0
 00000043 0
 00000042 0
 00000041 0
 00000040 0
 0000003f 0
 0000003e 0
 0000003d 0
 0000003c 0
 00000034 0
 00000033 0
 00000032 0
 00000031 0
 00000030 0
 0000002e 0
 0000002d 0
 0000002c 0
00000064 (D) Z:\media\AKI\ONLINE GAMES\Steam\steamapps\common\skyrim\SkyrimLauncher.exe
 00000065 0 <==
System information:
    Wine build: wine-1.4
    Platform: i386
    Host system: Linux
    Host version: 3.2.0-29-generic-pae

I'm getting frustrated. It has been 2 weeks trying to resolve this. I don't know what is wrong.

Curious fact: with playonlinux I download steam platform, I sign in in my account and the games are there, but I have to download them...Again!!! that too.. to my computer, not to the hard drive.

Could anyone please when have some free time can help me with this?

Thank you so much in advanced.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu wine Edit question
Assignee:
No assignee Edit question
Last query:
2012-09-04
Last reply:
2012-09-11

Are the games installed on the USB drive, Windows games?

Yes, the games are installed in my external hard drive. I did it in that way so I can play them in any computer or OS. It works in others computers (all with windows) but only in Ubuntu it doesn't works. As I said before there is only one game that runs in both OS, is Shaiya.

Then they won't work. think about it, if games worked like thathen NOBODY would buy games, they could simply zip up the files the installer adds and give them to the world. This is not ho games and pretty much ANY application in Windows installs. Files are copied all over the file system as well as numerous registry entries.

Did you seriously think that is how games installed...wow....

Well Mister,

I thought this forum was to help and at the same time learn. Not to ridicule a person. If somebody come here for help instead treating a person like a stupid, why not to teach them?

For your kindly information, I DO run my games from an external hard drive. YES it is possible.!! I have one lenovo, one Dell and one HP at home. All of them windows 7. In the HP I have the 2 OS. (Ubuntu and Windows7). In the 3 computers I run any of my games FROM THE HARD DRIVE. That there are files installed in the computer registry even if I run the game from an external hard drive, yes. I KNEW THAT. Still possible to run the same game in another computer. What I need is just to install the platform (Steam), or Pando for Perfect World, Aeria for Shaiya..so on.

 To bring some light to you: These games are online, FREE, so yes, you download , unzip...but of course you don't play them so you don't know. (Your "nobody would buy games"..doesn't apply here).

I just wanted to know how to run them from Ubuntu. ALREADY I'm running Shaiya from Ubuntu. Very easy, I download Aeria Ignite connect the external hard drive and play. Impossible right? The other games gave an error, I just wanted to know what is missing or if is wine that can't support the games. That was all.

Do you have any idea how many people would like to try Ubuntu? but doesn't dare to start or to ask because somebody rude as you will try to ridicule them. Help the begginners, they are the future experts, you never now. And, if you don't know the answer, don't try to reply.

Did you seriously think is not possible to download, unzip and play games from an external hard drive?...wow..get updated!!!

Yes because the extra files needed for the app to run re in the Windows install, the majority of the data needed for the application may well be on the USB storage but there is a lot of complex data which is secreted throughout your Windows OS in various folders. You will not be able to run the games in Wine in this manner unless they are portable applications (Which are specially coded to run as such) and do not have files in any other location other than the one they install to.

You will need to search online to find the files that are within your Windows OS and copy them to the relevant place in ~/.wine/drive_c as well as copy the necessary registry entries into the Wine registry. In short, you can save yourself a tonne of work by simply installing the application in Wine.

Can you help with this problem?

Provide an answer of your own, or ask quinones for more information if necessary.

To post a message you must log in.