Wine app Newsbin unable to connect to ssl servers

Asked by hairybiker on 2012-06-16

Under 12.04 using openssl 1.0.1-4ubuntu5.2 with wine 1.55
Newsbin is unable to connect to ANY ssl servers, including the regsitration server.
The error from NB is
ERROR InterSocket - Error: SSL Negotiation Failed, Host: Error: SSL Connection Failed: 5 Error 0 Success.

and from the developer
define SSL_ERROR_SYSCALL 5 /* look at error stack/return value/errno */
This is error 5. It's saying something in Wine's socket layer's dropping the ball.

I have tried Wine 1.4, 1,55, POL versions of the same all with the same error.

It seems the same error as which is related to mail servers but ...

Question information

English Edit question
Ubuntu wine Edit question
No assignee Edit question
Last query:
Last reply:
hairybiker (xbox-robsonfamily) said : #1

I have also raised this on Winehq

A "fix" is to change the ptrace to 0
echo 0|sudo tee /proc/sys/kernel/yama/ptrace_scope
but this is not a solution just a workaround.

Ken Sharp (kennybobs) said : #2

If you have opened bugs than this should be considered answered?

Can you help with this problem?

Provide an answer of your own, or ask hairybiker for more information if necessary.

To post a message you must log in.