Wicd asking for a password on computer start-up.

Asked by Ken on 2009-12-22

I've just started getting a pop-up box asking for a password whenever I start my computer. Is there a way to prevent this, it is a new thing.

The box/message is:-

" Wicd needs to access your computer's network cards "

Entering my sudo password clears the box and allows the computer to finish loading the desktop and the network connection.

Appreciate any advice.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu wicd Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
2009-12-22
Last query:
2009-12-22
Last reply:
2009-12-22
Ken (ken-cook) said : #1

Apologies, forgot to add: Ubuntu 9.10.
Plus tried re-installing Wicd a couple of times without success.

Ken (ken-cook) said : #3

Hi Marco,

Thanks for the response.

I have already checked that thread. If your referring to the square bracket theory in /etc/wicd/wired-settings.conf , this isn't the case with my installation (there are no redundant brackets).

http://linux.derkeiler.com/Mailing-Lists/Ubuntu/2009-11/msg00318.html

Seem this user solve installing network-manager then reinstall wicd (two-reboot required).

Hth

Ken (ken-cook) said : #5

Hi Marco,

I'd seen this one too as a repost somewhere, but I didn't try it.

I'm a little nervous of this route purely because it leaves me open to the possibility loosing all internet connection, hence other possible solutions/query avenues if I run into problems. I must also admit, I'm not very well practiced on the apt-get or in general on terminal commands. Do you think using synaptic to load/re-load the packages would be okay?

What I don't understand, is this is not an error message, its a 'by design' password entry box, complete with the keys symbol. This leads me (in my simplistic way!) to think that there is a known option/software switch to control this password requirement. Does that make sense/seem logical?

I'm open to trying network-manager and then reverting back to wicd, any tips on how I can add any safety net (not loose network connections) to the procedure?

Thanks.

Soul-Sing (soulzing) said : #6

is it a default keyring password pop-up? if so: rm ~/.gnome2/keyrings/default.keyring

Please also try this i have same issue as yours and doing this i just solved it:

Open a Terminal from the menu Applications → Accessories → Terminal and type or better copy and paste the row below (be sure to copy also the end dot in the row) :

sudo update-rc.d -f wicd remove; sudo update-rc.d wicd start 06 2 3 4 5 . stop 20 0 1 6 .

the system ask you a password give your user password, you will not see nothing when you type it, then press enter

Then reboot the pc

Hth

Ken (ken-cook) said : #8

Hi Marco,

I didn't realise you had the same problem.

I hate to keep saying it, but I'd seen (and tried) this one before as well. However, from memory, there looked to be a little more to your command line, perhaps even the dot I'd missed previously, so I tried it again and... it worked! :)

Many thanks for tracking that down. Not important, but did you discover what caused your problem or how the fix works?

Hi too leoquant,

Yes, it is a default 'style' pop-up, with keyring logo, but it isn't a 'login' password as such, it is a request for a password to start the network via Wicd. I don't know if your fix would have worked, I noticed Marco's reply first which seems to have cured the problem.

Thanks again guy's and best seasons wishes.

Ken (ken-cook) said : #9

Thanks marcobra (Marco Braida), that solved my question.

The solution i sent you is a solution that i have seen here https://bugs.launchpad.net/wicd/+bug/250197 but was not working for me, so i have done some little changes to force the start of wicd very early at system startup and now seems to works not only for me.

Best regards

trigoman05 (helenacoder) said : #11

Woot! This fix worked for me! Thank you :D

zydeckt (zydeckt) said : #12

Hi,
I run Ubuntu 9.10 on my PC; Wicd asks my root password on GNOME start-up only if I set concurrency startpar-style in /etc/init.d/rc. I solved this problem by adding:

exec wicd

in a new line of /etc/init/networking.conf.
Moreover if I reset CONCURRENCY=NONE wicd doesn't ask my root password if I delete "exec wicd" in networking.conf.
Hope this can be help you.
Best regards.

zydeckt (zydeckt) said : #13

Sorry...Wicd is installed on my PC at version 1.6.2.2.

dave (worter) said : #14

hi zydeckt,

i found your post a little confusing, but also very helpful. in my /etc/init.d/rc file the concurrecy was already set at 'none' ,but by typing the ' exec wicd' in the /etc/init/networking.conf file my... 'Wicd needs to access your computer's network cards' problem seems to have disappeared.

thanks
-dave

MilchFlasche (robertus0617) said : #15

I hate to say, but the
sudo update-rc.d -f wicd remove; sudo update-rc.d wicd start 06 2 3 4 5 . stop 20 0 1 6 .
method, and the "install network-manager and reinstall wicd" method don't work for me unfortunately.

MilchFlasche (robertus0617) said : #16

Okay I take back my words. My Wicd daemon didn't start after reinstalling and wicd-client asked me for sudo password, because I didn't delete the redundant brackets in the /etc/wicd/wired-settings.conf again. So I remembered that and modified the file, rebooted and now Wicd gets back to normal starting, without asking me sudo password. (Using Kubuntu, I have to set my network manager to Wicd in System Settings too).

Now I have to face another problem that Wicd does not connect to WPA properly...

Cerin (chrisspen) said : #17

Thanks Marco. I encountered this problem on 10.04 after I installed Network Manager to test the OpenVPN GUI, and then later uninstalled NM and re-installed Wicd. It was very frustrating, but your solution fixed it perfectly.

gregrwm (gregrwm) said : #18

iirc when i first installed lucid/lubuntu/wicd not long ago it was not available via ubuntu repos, i installed via ppa. now lubuntu is available via ubuntu repos, and *requires* network-manager. adding wicd does not remove nm. i remove nm manually. then if i add ubuntu-desktop or edubuntu-desktop-kde nm is again required (and i remove it again). my problem now is that wicd starts seemingly too early and fails, syslog says "dhclient: Bind socket to interface: No such device", leaving me to start wicd manually, which does work. if i launch a desktop or wicd-curses first, wicd won't be running yet, and the client will require a password to launch it.