wget 1.18 in xenial

Asked by Stas

Is it possible to bump wget in Xenial to 1.18 or greater, it has an important change(from Changelog):

* When Wget is built with libiconv, it now converts non-ASCII URIs to
  the locale's codeset when it creates files. The encoding of the
  remote files and URIs is taken from --remote-encoding, defaulting to
  UTF-8. The result is that non-ASCII URIs and files downloaded via
  HTTP/HTTPS and FTP will have names on the local filesystem that
  correspond to their remote names.

Which fixes incorrect filenames for non-ASCII files.

Question information

English Edit question
Ubuntu wget Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Manfred Hampl (m-hampl) said :

I suggest that you create a bug report to backport the 1.18 version from yakkety to xenial.

As a quick workaround you might try downloading the .deb file for wget on yakkety and manually installing it on your system
Maybe you can also find a PPA with such version.

Revision history for this message
Best actionparsnip (andrew-woodhead666) said :

I suggest you report a bug

Revision history for this message
Stas (ivaschenko-stas) said :

Thanks actionparsnip, that solved my question.