Connecting to 10.1.1.19:80... connected... 407 authentication required

Asked by gnaveen garg on 2013-01-07

naveen@naveen-Extensa-4620:~$ wget http://www.skype.com/go/getskype-linux-ubuntu-32/skype-ubuntu-precise_4.1.0.20-1_i386.deb

--2013-01-09 00:57:05-- http://www.skype.com/go/getskype-linux-ubuntu-32/skype-ubuntu-precise_4.1.0.20-1_i386.deb
Connecting to 10.1.1.19:80... connected.
Proxy request sent, awaiting response... 407 Proxy Authentication Required
2013-01-09 00:57:05 ERROR 407: Proxy Authentication Required.

AND THIS IS WHAT I GET WHEN I ENTER..... sudo gedit /etc/apt/apt.conf
Acquire::http::proxy "http://username:password@10.1.1.19:80/";
Acquire::https::proxy "https://username:password@10.1.1.19:80/";
Acquire::ftp::proxy "socks://username:password@10.1.1.19:80/";
Acquire::socks::proxy "socks://username:password@10.1.1.19:80/";

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu wget Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2013-01-10
Last query:
2013-01-10
Last reply:
2013-01-08

Use gksudo with GUI apps (like gedit), not sudo.

Can you download the file ok with the web browser?
Do you use a proxy for web access?

Best Manfred Hampl (m-hampl) said : #2

I think the problem is that wget is not using the apt settings for proxy.
For wget when called directly, you have to set the proxy inside .wgetrc or set the http_proxy environment variable

gnaveen garg (ngnaven) said : #3

Thanks Manfred Hampl, that solved my question.