How do you build libwebkitgtk-1.0 from the webkit trunk?

Asked by Rob Crowell on 2011-09-13

Hello,

I am working off the WebKit svn trunk http://svn.webkit.org/repository/webkit/trunk and I'm not sure how to build this library. I am building libwebkitgtk-3.0.so.0 but I need the 1.0 version of this library (trying to build pywebkitgtk which seems to require webkit-1.0 >= 1.1.10).

Can anyone provide any pointers on how the 1.0 version of this library is built? Do I need to use an older version of webkit? Is there a flag I can pass to build this previous version?

For reference, I'm currently building the 3.0 version via:
$ Tools/Scripts/build-webkit --gtk

Thanks!

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu webkit Edit question
Assignee:
No assignee Edit question
Last query:
2011-09-13
Last reply:

Can you help with this problem?

Provide an answer of your own, or ask Rob Crowell for more information if necessary.

To post a message you must log in.