sudo apt-get -f install libv4l-0

Asked by Begueradj on 2015-05-21

Ubuntu 14.04 LTS:

begueradj@begueradj-darwin:~/Desktop/secrethacking$ sudo apt-get install libv4l-0
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libv4l-0 : Depends: libv4lconvert0 (= 1.6.0+r2609-2~ubuntu14.04.1) but 1.0.1-1 is to be installed
            Breaks: libv4l-0:i386 (!= 1.6.0+r2609-2~ubuntu14.04.1) but 0.6.4-1ubuntu1 is to be installed
 libv4l-0:i386 : Conflicts: libv4l-0 but 1.6.0+r2609-2~ubuntu14.04.1 is to be installed
 libv4lconvert0 : Breaks: libv4l-0:i386 (< 0.8.5-4) but 0.6.4-1ubuntu1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
begueradj@begueradj-darwin:~/Desktop/secrethacking$ sudo apt-get -f install libv4l-0
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libv4l-0 : Depends: libv4lconvert0 (= 1.6.0+r2609-2~ubuntu14.04.1) but 1.0.1-1 is to be installed
            Breaks: libv4l-0:i386 (!= 1.6.0+r2609-2~ubuntu14.04.1) but 0.6.4-1ubuntu1 is to be installed
 libv4l-0:i386 : Conflicts: libv4l-0 but 1.6.0+r2609-2~ubuntu14.04.1 is to be installed
 libv4lconvert0 : Breaks: libv4l-0:i386 (< 0.8.5-4) but 0.6.4-1ubuntu1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

How to resolve this problem ?
Thank you in advance.
Begueradj

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu webbrowser-app Edit question
Assignee:
No assignee Edit question
Solved by:
Begueradj
Solved:
2015-05-21
Last query:
2015-05-21
Last reply:
2015-05-21
Manfred Hampl (m-hampl) said : #1

What is the output of the commands

uname -a
lsb_release -crid
apt-cache policy libv4l-0 libv4lconvert0 libv4l-0:i386

Did you use a PPA in the past, that you now have disabled (I assume it must have been ppa:libv4l/stable)?

Begueradj (beg-bill) said : #2

I changed the content of /etc/apt/sources.list to:

begueradj@begueradj-darwin:~/Desktop/secrethacking$ cat /etc/apt/sources.list
deb http://fr.archive.ubuntu.com/ubuntu/ trusty main restricted universe multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ trusty-updates main restricted universe multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ trusty-proposed main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ trusty partner
deb http://extras.ubuntu.com/ubuntu/ trusty main

Then I run update and the installation went Ok.
Begueradj