Webalizer with bunzip2 support

Asked by Urs Mueller on 2020-06-28

Webalizer V2.23-08 (Linux 4.15.0-106-generic x86_64) locale on Ubuntu 18.04.4 LTS
Does it support bunzip2 for managing bzip2 compressed logs?
I do get strange errors about no entries in the log and entries, that are too long.
The webalizer homepage says it supports bzip2/bunzip2 if set on compile time.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu webalizer Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2020-06-29
Last query:
2020-06-29
Last reply:
2020-06-29
Manfred Hampl (m-hampl) said : #1

I d not see a dependency on bzip2 or libbz2 in https://launchpad.net/ubuntu/bionic/amd64/webalizer/2.23.08-3 so I assume that is not the case.

Urs Mueller (info-urs-mueller) said : #2

Thank you, how to get the maintainers into including it?
I could build it myself, but I prefer a supported package.

Best Manfred Hampl (m-hampl) said : #3

Ubuntu copies that package from Debian. For getting that function into the Ubuntu package it has to implemented in the Debian package first. I suggest that you create a related bug report in the Debian bug tracker https://bugs.debian.org/src:webalizer and another one in the Ubuntu bug tracker with a reference to the Debian bug.

Urs Mueller (info-urs-mueller) said : #4

Thanks Manfred Hampl, that solved my question.