Ubuntu

vsftpd does not allow local logins

Asked by Frozen-Solid on 2012-04-26

On my fresh install of Ubuntu 12.04 64bit Server Edition I installed vsftpd using apt-get. I then edited the vsftpd configuration so that it has these options, and everything else commented out.

listen=YES
anonymous_enable=NO
local_enable=YES
write_enable=YES
dirmessage_enable=YES
use_localtime=YES
xferlog_enable=YES
connect_from_port_20=YES
chroot_local_user=YES
chroot_list_enable=YES
chroot_list_file=/etc/vsftpd.chroot_list
secure_chroot_dir=/var/run/vsftpd/empty
pam_service_name=vsftpd
rsa_cert_file=/etc/ssl/private/vsftpd.pem

When trying to login using a valid username and password I get the error "530 Incorrect Login"

the following errors appear in /var/log/auth.log

vsftpd: PAM unable to dlopen(pam_shells.so): /lib/security/pam_shells.so: cannot open shared object file: No such file or directory
vsftpd: PAM adding faulty module: pam_shells.so
vsftpd: pam_unix(vsftpd:auth): check pass; user unknown
vsftpd: pam_unix(vsftpd:auth): authentication failure; logname= uid=0 euid=0 tty=ftp ruser=<userid> rhost=127.0.0.1
vsftpd: pam_winbind(vsftpd:auth): getting password (0x00000388)
vsftpd: pam_winbind(vsftpd:auth): pam_get_item returned a password

The same exact settings worked on my 12.04 32 bit Server Edition. What might be wrong?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu vsftpd Edit question
Assignee:
No assignee Edit question
Last query:
2012-04-26
Last reply:
2012-05-04
lumen (florian-jost-1988) said : #1

I had the same problem and found a solution on this site
http://www.cyberciti.biz/tips/centos-redhat-vsftpd-ftp-with-virtual-users.html

as Shailendra Kumar said:

Edit the vsftpd configuration file.

virtual_use_local_privs=YES
pam_service_name=vsftpd.virtual

Can you help with this problem?

Provide an answer of your own, or ask Frozen-Solid for more information if necessary.

To post a message you must log in.