VNC extension well out of date

Asked by Toby Gray on 2009-07-01

Can we PLEASE have a version of a package (ANY package) that contains a version of libvnc.so that matches a recent distribution's Xorg version?
vnc4server hasn't been updated AT ALL since at least Hardy, and even that update was only a minor one (and not in line with Hardy's version of Xorg). The "current" version of vnc4server's libvnc.so appears to be for Xorg 1.0.2, the same version as Dapper's xserver-xorg-core. Since then the xserver-xorg packages have been updated to 1.4, 1.5, 1.6.0 and 1.6.1 (plus whatever versions were in Edgy and Fiesty) without a single update to vnc4server.
It would appear that my only recourse is to build the damn thing myself, meaning I have to do a complete X build just to get one lousy module. Personally, I don't understand why you don't just include this module in xserver-xorg-core anyway since people don't have to load it if they don't want to use it.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu vnc4 Edit question
Assignee:
No assignee Edit question
Solved by:
Toby Gray
Solved:
2009-07-01
Last query:
2009-07-01
Last reply:
2009-07-01

Not everyone uses VNC. I certainly don't due to its poor performance and lack of security. This would be bloat for many users. Have you tried finding a PPA with a later version on it? Is there anything malfunctioning with vnc4server?

If you have a recommendation for packaging then you can do this constructively on the Ubuntu website as a proposal for future functionality.

Toby Gray (toby-yargybot) said : #2

I realise that not everyone uses VNC. Many common packages include functionality that "not everyone" who installs the package uses.
As for lack of performance, vnc clients talking to Xvnc over a (W)LAN are fine for general "office work" applications in my opinion. However, it seems that the only way to get equivalent functionality with current packages is to use a polling vnc server (eg. x11vnc), where performance is a much bigger issue. I only use vnc over a private LAN behind a firewall, so security is hardly an issue for me. Regardless, any particular users' views on the performance and/or security of VNC are hardly relevant here and don't explain why vnc4server is so far behind xserver-xorg-*.
I hadn't tried finding a PPA, and having had a brief look at the PPAs area of the website I'm not really sure how I would go about finding what I need there in any reasonable amount of time.
Strictly speaking, there is not anything "malfunctioning" with vnc4server (hence me coming here rather than filing a bug report). On the other hand, the libvnc.so module from the vnc4server package does not work with the standard X server in the same distro since at least Hardy, and possibly as far back as Edgy. Likewise kdm (for example) does not work with Xvnc from the vnc4server package, and presumably many other X-oriented packages will require extensions etc that are not offered by such an outdated server.

As for making a packaging recommendation, the thing about including the vnc module in the xserver package was really just a throwaway comment in passing. I don't really care how it's pacakaged if it's at least in sync. It just seems logical to build libvnc.so along with the rest of xserver-xorg-core.

Thats how things change, you submit what you see as logical and it will be considered by the devs. If it is deemed good then they will do it, if not then it will be discarded. Doesnt hurt to suggest things at all.

Ok running VNC over your own LAN is fine, Just don't do it over WAN without an SSH tunnel. If you are running over LAN, you could use X forwarding instead, it is default in openssh-server and as long as you connect with:

ssh -X username@server then it will connect and you can run the remote gui apps. (If you are using windows as a client you will need to run xming to give you the x server libs)

If you are dead set on VNC then you will need to simply websearch until you find one that has what you need, There are milions of PPAs with apps for your system.

I would type more but work calls.

Peace

Toby Gray (toby-yargybot) said : #4

Built my own libvnc.so. See post at bug #260815.
X forwarding doesn't give me what I want either. Running a local X server and connecting to the remote kdm via XDMCP was OK, but I really prefer being able to access a single KDM-managed session from wherever I happen to be without the need to log in and out (or close and open apps like Firefox and Konsole that don't play nice running in multiple sessions owned by the same user) every time I move to another PC.

I'm going to hit the "Problem Solved" button now because my immediate problem here IS solved, however the fundamental problem of vnc4server being way behind the other "X stuff" remains.