Vmplayer3.1 no loger works after 11.04 to 11.10 upgrade

Asked by Eugene

After upgrading from 11.04 to 11.10, VMPlayer 3.1 no longer works.

Platform is 64 bits, running X840 AMD.

When I launch VMPlayer, it launcher the VMWare Kernel Module Updater, which immediately crashes out with an error stating

"Unable to build kernel module"

It tells me to look at /tmp/vmware-root/setup-13532.log for details.

I have not yet found a way to look at this file as my own system tells me I do not have permission to access this file!

Does anybody know the cause and solution please?

Question information

English Edit question
Ubuntu vmware-player Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
Revision history for this message
Eugene (leugena) said :

Hi All

Thanks for the feedback. I am still nowhere nearer an answer. I have tried running the patches, but the *.sh file comes back with a checksum error, and the *.patch files comes back with other errors

My kernel version is 3.0.0-12-generic.

Any other ideas?


Revision history for this message
Eugene (leugena) said :

Hi All

I have resolved the problem. I do not know which step in particular helped me, but this is more or less what I did

1.) Ripped out all VMware files on the system, and created a clean directory, filled with a fresh download of VMWarePlayer4
2.) Used apt-get to install the development headers for kernel 3.0.0-12-generic
3.) Relaunched the installer with sudo ....
4.) Successful install, and for the first time in a few weeks, I can get to my VM's