Cannot install anything - Kubuntu - VMWare

Asked by Scott Moore

I'm using VMWare on Windows 7. I installed Kubuntu. I can use the desktop and applications just fine but I cannot install anything via the GUI. For example, I went to Applications > Internet > Firefox (the icon to install it) and I got the error "authentication error qapt batch installer This operation cannot continue since proper authorization was not provided".

The problem is, the system never asked me for authorization. I know that a box is supposed to pop up asking for my password for root access but it doesn't appear. It's as if the OS is expecting me to give authorization it never asks me for.

I was able to do it on the command line. I'm a noob but I know enough to "sudo apt-get install firefox" and that did work. But when I went to install additional wallpaper, I got the same error.

BTW, I am using new versions of everything, Kubuntu with a good MD5 hash and new VMWare. VMWare Tools are also installed in Kubuntu (it appears VMWare did this on it's own when it installed Kubuntu.

I'm a noob to Linux and I'm trying to learn how to use this OS. Any ideas are greatly appreciated.

Question information

English Edit question
Ubuntu vmware-player Edit question
No assignee Edit question
Solved by:
Scott Moore
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

Can you give the output of:

sudo apt-get update; lsb_release -a


Revision history for this message
Scott Moore (scottbomb) said :

Yes, thank you. Here it is:

Ign natty InRelease
Ign natty-security InRelease
Ign natty InRelease
Ign natty-updates InRelease
Hit natty Release.gpg
Hit natty-security Release.gpg
Hit natty Release.gpg
Hit natty Release
Hit natty-security Release
Hit natty-updates Release.gpg
Hit natty/main Sources
Hit natty-security/main Sources
Hit natty Release
Hit natty/main amd64 Packages
Ign natty/main TranslationIndex
Hit natty-security/restricted Sources
Hit natty-security/universe Sources
Hit natty-security/multiverse Sources
Hit natty-security/main amd64 Packages
Hit natty-security/restricted amd64 Packages
Hit natty-updates Release
Hit natty-security/universe amd64 Packages
Hit natty-security/multiverse amd64 Packages
Ign natty-security/main TranslationIndex
Ign natty-security/multiverse TranslationIndex
Ign natty-security/restricted TranslationIndex
Ign natty-security/universe TranslationIndex
Hit natty/main Sources
Hit natty/restricted Sources
Hit natty/universe Sources
Hit natty/multiverse Sources
Hit natty/main amd64 Packages
Hit natty/restricted amd64 Packages
Hit natty/universe amd64 Packages
Hit natty/multiverse amd64 Packages
Ign natty/main TranslationIndex
Ign natty/multiverse TranslationIndex
Ign natty/restricted TranslationIndex
Ign natty/universe TranslationIndex
Hit natty-updates/main Sources
Hit natty-updates/restricted Sources
Hit natty-updates/universe Sources
Hit natty-updates/multiverse Sources
Hit natty-updates/main amd64 Packages
Hit natty-updates/restricted amd64 Packages
Hit natty-updates/universe amd64 Packages
Hit natty-updates/multiverse amd64 Packages
Ign natty-updates/main TranslationIndex
Ign natty-updates/multiverse TranslationIndex
Ign natty-updates/restricted TranslationIndex
Ign natty-updates/universe TranslationIndex
Ign natty/main Translation-en_US
Ign natty-security/main Translation-en_US
Ign natty-security/main Translation-en
Ign natty-security/multiverse Translation-en_US
Ign natty-security/multiverse Translation-en
Ign natty-security/restricted Translation-en_US
Ign natty/main Translation-en
Ign natty-security/restricted Translation-en
Ign natty-security/universe Translation-en_US
Ign natty-security/universe Translation-en
Ign natty/main Translation-en_US
Ign natty/main Translation-en
Ign natty/multiverse Translation-en_US
Ign natty/multiverse Translation-en
Ign natty/restricted Translation-en_US
Ign natty/restricted Translation-en
Ign natty/universe Translation-en_US
Ign natty/universe Translation-en
Ign natty-updates/main Translation-en_US
Ign natty-updates/main Translation-en
Ign natty-updates/multiverse Translation-en_US
Ign natty-updates/multiverse Translation-en
Ign natty-updates/restricted Translation-en_US
Ign natty-updates/restricted Translation-en
Ign natty-updates/universe Translation-en_US
Ign natty-updates/universe Translation-en
Reading package lists... Done
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty

Revision history for this message
actionparsnip (andrew-woodhead666) said :

Looks fine, ok run:

sudo apt-get -y upgrade

Is it smooth?

Revision history for this message
Scott Moore (scottbomb) said :

It worked! Thanks!! From now on, I'll make sure the distro checks for updates (I believe that's what your command did...) when I install it.

Revision history for this message
actionparsnip (andrew-woodhead666) said :

No worries, glad you got the gold :)