How to set timeout=0 in Grub for a newly created VM?

Asked by Matthew_A on 2009-08-03

I noticed during build time the following output is displayed to the log:

grep: /boot/config*: No such file or directory

Is it looking for *any* file that matches /boot/config* to get default grub values? I want to set timeout 0 to my guests. Default is 3.

Thank you

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu vm-builder Edit question
Assignee:
No assignee Edit question
Last query:
2009-08-04
Last reply:
2009-08-04

gksudo gedit /boot/grub/menu.lst

you can set it there. If the VM is kde based then use

kdesudo kate /boot/grub/menu.lst

if you prefer command line use:

sudo vi /boot/grub/menu.lst
or
sudo nano /boot/grub/menu.lst

etc

I do not recommend doing this as you will not be able to boot to recovery mode should you need it.

Matthew_A (plattze) said : #2

Sorry, I shoujld have clarified. I know how to set the timeout manually in the Guest, but I want to set it at creation time.

Is the only option to change "timeout 3" to "timeout 0" in menu.lst from inside an --exec script?

I ask because I noticed from the output log that it's trying to grep "/boot/config*" so I thought maybe I could create a /boot/config_grub_guest file that contained "timeout 0" or any other specific (such as splash images) for any newly created guest(s).

i think you would have to reauthor the install CD if you want to changed at install / creation time. If you create a script to run on each system after it is installed then you could do it that way.

Can you help with this problem?

Provide an answer of your own, or ask Matthew_A for more information if necessary.

To post a message you must log in.