no sound when playing movies

Asked by Lori on 2009-09-13

Im having trouble gettint the sound to play when I start a movie that I've downloaded. Pictures fine but no sound I've tried VLC and MPlayer,
I've had this problem before and it was fixed and when went to try the same thing as before the feature I need to change is not there in the audio preferences in VLC player.
I do have sound with other programs

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu vlc Edit question
Assignee:
No assignee Edit question
Solved by:
Tom
Solved:
2009-09-13
Last query:
2009-09-13
Last reply:
2009-09-13
Lori (lowee01) said : #1

I've solved it
Thank you

Lori (lowee01) said : #2

Sorry I thought I had it but I don't
I changed the Output setting from ALAS to Linux OSS and I still have no sound when I play a movie, the picture is fine

Daniel Hollocher (chogydan) said : #3

are you running regular ubuntu? have you tried totem?

Tom (tom6) said : #4

Hi :)

Yes, Totem often loads extra codecs and things if required to play a format that your Ubuntu install hasn't tried to play before.

I would also recommend that you work all through this worksheet
https://help.ubuntu.com/community/Medibuntu
as a good first step in getting almost everything sorted out for al your multimedia. If sound still doesn't work then this guide might help
https://help.ubuntu.com/community/SoundTroubleshootingProcedure

Good luck and regards from
Tom :)

Tom (tom6) said : #5

Err in the medibuntu guide just miss out the optional step for now. I am thinking about going for that in a few months time but i am not ready for it yet.

Lori (lowee01) said : #6

I have Ubuntu 8.04 and I have not tried totem but I will

Lori (lowee01) said : #7

I've installed Totem and I have sound now.
I would still Like to find out why the VLC worked before and now it does not, I think its an undated version from when it worked before.

Best Tom (tom6) said : #8

Oh, err MPlayer is usually better at playing anything tricky bt Totem is easy to access. On the top taskbar click on

Applications - Sound & Video - Totem

or right click on a movie file and select "Movie Player" or "Totem", either option should open Totem. I think the thing that will fix this is copying and pasting the appropriate lines from the Medibuntu page onto the command-line
https://help.ubuntu.com/community/UsingTheTerminal#Starting%20a%20Terminal

Good luck and regards from
Tom :)

Tom (tom6) said : #9

Oh! Nicely done :))

At a guess you might find that VLC does work properly now. Whenever you isntall a new package it tends to daw in other pakages that it depends on to work. We call these "dependencies". Often a dependency (or even a package) will help ther packages/programs to gain the extra functionality they lacked previously. Linux is amazing the way these things all fit together!

Any luck with VLC or MPlayer?
Regards from
Tom :)

Tom (tom6) said : #10

I have just been thinking and maybe you just need to run an update manager. You can do this from Synaptic Package Manager
https://help.ubuntu.com/community/SynapticHowto

Just click on the "Mark all upgrades" button and then click on the "Apply" button

I hope this helps!
Regards again from
Tom :)

Lori (lowee01) said : #11

I'll try copying the code into the command line and I think I will stick with Totem now
Thank you

Tom (tom6) said : #12

Brilliant, nocely done :)))
Congrats on sorting this out so easily!
Regards from
Tom :)