vlc play music but not videos

Asked by soukis on 2009-02-04

hello.
i'm new in linux and i need your help please.i have ubuntu 8.10.i use vlc cause i need to have subtitles.the problem is that i can't see videos on vlc.when i choose one video to play start for les than a sec and after stop.with music is ok.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu vlc Edit question
Assignee:
No assignee Edit question
Solved by:
Tom
Solved:
2009-02-13
Last query:
2009-02-13
Last reply:
2009-02-07
arochester (arochester) said : #2

...for 8.10 also look at https://help.ubuntu.com/community/Medibuntu for the correct repository...

Tom (tom6) said : #3

All i have is questions, sorry ...

Are you using an ati graphics card?
Can you play movies in Totem? (but without subtitles?)

Thanks for your answers in advance :)
Regards from
Tom :)

soukis (s-soukous) said : #4

Yes i have ATI graphic card and no i can't play any video in Totem.You think that happent cause of my graphic card?

Tom (tom6) said : #5

Nope, i have ati too and it's fine. But it might be worth getting the drivers for ati by going up to the top taskbar and then click on

System - Administration - Hardware Drivers

Also its definitely tweaking a setting. Again go up to the top taskbar and click on

Applications - Accessories - Terminal

Into the terminal/command window/console type

gstreamer-properties

and a handy application opens. Click on the "Video" tab and change the top option, "Output" from "Automatic" to " ...(no Xv)" close the box and things generally should work much better now. No mare flashing screens and stuff. Try Totem again and see what i mean.

Good luck and regards from
Tom :)

Best Tom (tom6) said : #6

If you are still having trouble with this then please post it as a new question. Only the most recent questions tend to get looked at so posting/reposting a question just before america arrives online gives the best chance of getting a good few answers.

If the problem has been resolved then please follow the link to the forum thread and mark it as Solved.

Good luck and many regards from
Tom :)

soukis (s-soukous) said : #7

Thanks Tom, that solved my question.

Tom (tom6) said : #8

Thanks, nicely done
Regards from
Tom :)

Play mp3 and dvd under Ubuntu install skype googleearth acroread and other stuffs using Medibuntu

First please install https://help.ubuntu.com/community/RestrictedFormats

You need to have extra repositories enabled..

Please first enable the universe and multiverse repository:

Open System → Administration → Software sources → [ Tab Ubuntu software ]

enable "Community-mainteined Open Source software ( universe )"
enable "Proprietary drivers for devices ( restricted )"
enable "Software restrictecd by copyright or legal issue ( multiverse )"

Close and confirm the repository reload.

Type the following command in a terminal (applications → accessories → terminal)

sudo aptitude install vlc smplayer mplayer

To get better dvd playback and optional packages here the medibuntu available software list http://packages.medibuntu.org/
you need to add the medibuntu http://www.medibuntu.org/ repository to your /etc/apt/sources.list file:
( here the medibuntu howto https://help.ubuntu.com/community/Medibuntu but see below )

In short type or better copy and paste the rows, below one row a time then press enter:

ubu_codename=$(sudo lsb_release -c | cut -d: -f 2 | sed 's/^[ \t]*//;s/[ \t]*$//')
sudo wget http://www.medibuntu.org/sources.list.d/$ubu_codename.list -O /etc/apt/sources.list.d/medibuntu.list
wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add - && sudo apt-get update

Now to install, type:

sudo apt-get update
sudo apt-get install ubuntu-restricted-extras libxine1-ffmpeg
sudo aptitude install libdvdread3 libdvdnav4 libdvdcss2 regionset gnome-mplayer
sudo aptitude install non-free-codecs w32codecs
sudo aptitude install gstreamer0.10-pitfdll gstreamer0.10-plugins-good
sudo aptitude install gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse

give your user password when requested, you don't see nothing when you type it, then press enter.

You can also install other Medibuntu repository provided optional software http://packages.medibuntu.org/ :

sudo apt-get install skype
sudo apt-get install googleearth
sudo apt-get install acroread

Hope this helps