VLC doesn't play DVD properly

Asked by sonjalin on 2008-12-28

I started a new thread because the previous problem is solved (https://answers.launchpad.net/ubuntu/+source/vlc/+question/34259https://answers.launchpad.net/ubuntu/+source/vlc/+question/34259)

I'm soon becoming mad with dvd playing... I have the same problem as John Fino did: vlc doesn't play a DVD properly. The piracy warnings are okay but then "the picture is all messed up (lots of colorful boxes, with maybe some picture, or just a green background). The video and sound (if there are any) stutter."

All the vlc plugins, libdvdnav4, libdvdplay0, libdvdread3, libdvdcss2, regionset and ubuntu-restricted-extras are installed by Synaptic.

I have also done this command:
sudo wget http://www.medibuntu.org/sources.list.d/hardy.list --output-document=/etc/apt/sources.list.d/medibuntu.list

It's a bit difficult for me to read English so maybe I haven't noticed something. Can anyone help?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu vlc Edit question
Assignee:
No assignee Edit question
Solved by:
sonjalin
Solved:
2009-01-19
Last query:
2009-01-19
Last reply:
2009-01-10
Torsten Franz (torsten.franz) said : #1

Hi,

do you have also installed the w32codecs?

You can install it on the consol/terminal width:

sudo apt-get install w32codecs

sonjalin (sonja-iki) said : #2

Hi!

I tried that but it says:

"Reading package lists... Done
Building dependency tree
Reading state information... Done
Package w32codecs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package w32codecs has no installation candidate"

Torsten Franz (torsten.franz) said : #3

Hi,

have you done this , too:

wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add - && sudo apt-get update

Than you have the right keys installed and you have update your source.list.

Than try again:

sudo apt-get install w32codecs

sonjalin (sonja-iki) said : #4

Hi,

I did that and managed but dvd is still not working. :/

Torsten Franz (torsten.franz) said : #5

Hi,
okay, please copy the content of the files:
/etc/apt/sources.list.d/medibuntu.list
and
/etc/apt/sources.list

and paste it hear.

Which Ubuntu you are use? 8.04 or 8.10?

Can you copy and paste the output from:

uname -a

sonjalin (sonja-iki) said : #6

Hi,

I have Ubuntu 8.04.

Here are the contents:

/etc/apt/sources.list.d/medibuntu.list

## Medibuntu - Ubuntu 8.04 LTS "hardy heron"
## Please report any bug on https://bugs.launchpad.net/medibuntu/
deb http://packages.medibuntu.org/ hardy free non-free
#deb-src http://packages.medibuntu.org/ hardy free non-free

/etc/apt/sources.list

#deb cdrom:[Ubuntu 8.04.1 _Hardy Heron_ - Release i386 (20080702.1)]/ hardy main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://fi.archive.ubuntu.com/ubuntu/ hardy main restricted
deb-src http://fi.archive.ubuntu.com/ubuntu/ hardy main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fi.archive.ubuntu.com/ubuntu/ hardy-updates main restricted
deb-src http://fi.archive.ubuntu.com/ubuntu/ hardy-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://fi.archive.ubuntu.com/ubuntu/ hardy universe
deb-src http://fi.archive.ubuntu.com/ubuntu/ hardy universe
deb http://fi.archive.ubuntu.com/ubuntu/ hardy-updates universe
deb-src http://fi.archive.ubuntu.com/ubuntu/ hardy-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fi.archive.ubuntu.com/ubuntu/ hardy multiverse
deb-src http://fi.archive.ubuntu.com/ubuntu/ hardy multiverse
deb http://fi.archive.ubuntu.com/ubuntu/ hardy-updates multiverse
deb-src http://fi.archive.ubuntu.com/ubuntu/ hardy-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://fi.archive.ubuntu.com/ubuntu/ hardy-backports main restricted universe multiverse
# deb-src http://fi.archive.ubuntu.com/ubuntu/ hardy-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository. This software is not part of Ubuntu, but is
## offered by Canonical and the respective vendors as a service to Ubuntu
## users.
# deb http://archive.canonical.com/ubuntu hardy partner
# deb-src http://archive.canonical.com/ubuntu hardy partner

deb http://security.ubuntu.com/ubuntu hardy-security main restricted
deb-src http://security.ubuntu.com/ubuntu hardy-security main restricted
deb http://security.ubuntu.com/ubuntu hardy-security universe
deb-src http://security.ubuntu.com/ubuntu hardy-security universe
deb http://security.ubuntu.com/ubuntu hardy-security multiverse
deb-src http://security.ubuntu.com/ubuntu hardy-security multiverse

uname -a

2.6.24-22-generic #1 SMP Mon Nov 24 18:32:42 UTC 2008 i686 GNU/Linux

Torsten Franz (torsten.franz) said : #7

Hi,

I think you should update your source list:

sudo apt-get update

and then you try again:

sudo apt-get install w32codecs

sonjalin (sonja-iki) said : #8

It didn't help. :/

sudo apt-get update
[sudo] password for sonja:
Hit http://fi.archive.ubuntu.com hardy Release.gpg
Ign http://fi.archive.ubuntu.com hardy/main Translation-en_US
Ign http://fi.archive.ubuntu.com hardy/restricted Translation-en_US
Ign http://fi.archive.ubuntu.com hardy/universe Translation-en_US
Ign http://fi.archive.ubuntu.com hardy/multiverse Translation-en_US
Hit http://fi.archive.ubuntu.com hardy-updates Release.gpg
Ign http://fi.archive.ubuntu.com hardy-updates/main Translation-en_US
Ign http://fi.archive.ubuntu.com hardy-updates/restricted Translation-en_US
Ign http://fi.archive.ubuntu.com hardy-updates/universe Translation-en_US
Hit http://packages.medibuntu.org hardy Release.gpg
Ign http://fi.archive.ubuntu.com hardy-updates/multiverse Translation-en_US
Hit http://fi.archive.ubuntu.com hardy Release
Hit http://security.ubuntu.com hardy-security Release.gpg
Ign http://security.ubuntu.com hardy-security/main Translation-en_US
Hit http://fi.archive.ubuntu.com hardy-updates Release
Ign http://security.ubuntu.com hardy-security/restricted Translation-en_US
Ign http://security.ubuntu.com hardy-security/universe Translation-en_US
Ign http://security.ubuntu.com hardy-security/multiverse Translation-en_US
Hit http://security.ubuntu.com hardy-security Release
Hit http://fi.archive.ubuntu.com hardy/main Packages
Hit http://fi.archive.ubuntu.com hardy/restricted Packages
Hit http://fi.archive.ubuntu.com hardy/main Sources
Hit http://fi.archive.ubuntu.com hardy/restricted Sources
Hit http://fi.archive.ubuntu.com hardy/universe Packages
Hit http://fi.archive.ubuntu.com hardy/universe Sources
Hit http://fi.archive.ubuntu.com hardy/multiverse Packages
Hit http://fi.archive.ubuntu.com hardy/multiverse Sources
Ign http://packages.medibuntu.org hardy/free Translation-en_US
Hit http://security.ubuntu.com hardy-security/main Packages
Hit http://fi.archive.ubuntu.com hardy-updates/main Packages
Hit http://fi.archive.ubuntu.com hardy-updates/restricted Packages
Hit http://fi.archive.ubuntu.com hardy-updates/main Sources
Hit http://fi.archive.ubuntu.com hardy-updates/restricted Sources
Hit http://fi.archive.ubuntu.com hardy-updates/universe Packages
Hit http://fi.archive.ubuntu.com hardy-updates/universe Sources
Hit http://fi.archive.ubuntu.com hardy-updates/multiverse Packages
Hit http://fi.archive.ubuntu.com hardy-updates/multiverse Sources
Hit http://security.ubuntu.com hardy-security/restricted Packages
Hit http://security.ubuntu.com hardy-security/main Sources
Hit http://security.ubuntu.com hardy-security/restricted Sources
Hit http://security.ubuntu.com hardy-security/universe Packages
Ign http://packages.medibuntu.org hardy/non-free Translation-en_US
Hit http://security.ubuntu.com hardy-security/universe Sources
Hit http://security.ubuntu.com hardy-security/multiverse Packages
Hit http://security.ubuntu.com hardy-security/multiverse Sources
Hit http://packages.medibuntu.org hardy Release
Hit http://packages.medibuntu.org hardy/free Packages
Hit http://packages.medibuntu.org hardy/non-free Packages
Reading package lists... Done
sonja@nightowl:~$ sudo apt-get install w32codecs
Reading package lists... Done
Building dependency tree
Reading state information... Done
w32codecs is already the newest version.
The following packages were automatically installed and are no longer required:
  linux-headers-2.6.24-19-generic python-zopeinterface libfltk1.1 vgabios
  libgavl0 python-setuptools python-pkg-resources gstreamer0.10-gnonlin
  linux-headers-2.6.24-19
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 24 not upgraded.

i suggest you to try gnome-mplayer

------ i drop below my note for vlc mp3 and...

Play mp3 and dvd under Ubuntu install skype googleearth acroread and other stuffs using Medibuntu

First please install https://help.ubuntu.com/community/RestrictedFormats

You need to have extra repositories enabled..

Please first enable the universe and multiverse repository:

Open System → Administration → Software sources → [ Tab Ubuntu software ]

enable "Community-mainteined Open Source software ( universe )"
enable "Proprietary drivers for devices ( restricted )"
enable "Software restrictecd by copyright or legal issue ( multiverse )"

Close and confirm the repository reload.

Type the following command in a terminal (applications → accessories → terminal)

sudo aptitude install vlc

To get better dvd playback and optional packages here the medibuntu available software list http://packages.medibuntu.org/
you need to add the medibuntu http://www.medibuntu.org/ repository to your /etc/apt/sources.list file:
( here the medibuntu howto https://help.ubuntu.com/community/Medibuntu but see below )

In short type or better copy and paste the rows, below one row a time then press enter:

ubu_codename=$(sudo lsb_release -c | cut -d: -f 2 | sed 's/^[ \t]*//;s/[ \t]*$//')
sudo wget http://www.medibuntu.org/sources.list.d/$ubu_codename.list -O /etc/apt/sources.list.d/medibuntu.list
wget -q http://packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add - && sudo apt-get update

Now to install, type:

sudo apt-get update
sudo apt-get install ubuntu-restricted-extras
sudo aptitude install libdvdread3 libdvdnav4 libdvdcss2 regionset gnome-mplayer
sudo aptitude install non-free-codecs w32codecs
sudo aptitude install gstreamer0.10-pitfdll gstreamer0.10-plugins-good
sudo aptitude install gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse

give your user password when requested, you don't see nothing when you type it, then press enter.

You can also install other Medibuntu repository provided optional software http://packages.medibuntu.org/ :

sudo apt-get install skype
sudo apt-get install googleearth
sudo apt-get install acroread

Hope this helps

sonjalin (sonja-iki) said : #10

Vlc doesn't play properly yet but gnome-player DOES, thanks a lot!