Help, I want my broken vlc back. (ubuntu 8.10)

Asked by bruced on 2008-12-23

Got an error during automatic updates regarding vlc, so I uninstalled vlc and related apps, and tried to:

 "sudo apt-get install vlc"

got the following errors:

The following packages have unmet dependencies:
  vlc: Depends: libavcodec1d (>= 0.cvs20070307) but it is not installable
       Depends: libavformat1d (>= 0.cvs20070307) but it is not installable
       Depends: vlc-nox (= 0.9.8a+x264snapshot20080928+faad2.6.1+2-1~ppa1) but it is not going to be installed
       Depends: vlc-plugin-pulse but it is not going to be installed
E: Broken packages

Tried using synaptic package manager to fix broken packages(no help)

Been looking around everywhere, and I can't fins a fix that'll work.

All help GREATLY appreciated.

Bruce

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu vlc Edit question
Assignee:
No assignee Edit question
Solved by:
bruced
Solved:
2008-12-23
Last query:
2008-12-23
Last reply:
bruced (bd-123us) said : #1

Sorry for the confusion, problem solved by:

Unchecked "unsupported updates" in admin>synaptic>settings>repositories>third-party

then ran in terminal:

sudo apt-get remove --purge vlc vlc-plugin-esd mozilla-plugin-vlc

then restarted synaptic-package-manager and marked for install :
vlc
mozilla-vlc-plugin

clicked apply, and wallah, vlc working again!

John Stiles (john-isabelle) said : #2

Thanks for solving that annoying break in service. For clarity "unsupported updates" is on the updates tab not third-party one.

Uncheck "unsupported updates" in admin>synaptic>settings>repositories>updates

Then continue with bruced instructions.

John Stiles (john-isabelle) said : #3

Sorry bruced solution does not work for me, checked or unchecked. Ref this forum for ideas on alternative ideas for package sources.

http://ubuntuforums.org/showthread.php?t=963619