vlc mplayer not working

Asked by jenglish5 on 2008-11-12

New to this Linux thing. Clean install of Ubuntu 8.10. Added the codecs and the included apps works fine with Mpeg 1 and 2, Mp3 but cannot play DVD. Installed vlc, mplayer, Amirok but none of those programs work. They wouldn't even load. I clicked their icons and nothing happen. Amerok splash screen did come on but will not load any further.

I added the "restricted content" but vlc, mplayer, Amerok will not work.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu vlc Edit question
Assignee:
No assignee Edit question
Last query:
2008-11-12
Last reply:
2008-11-12
Gord Allott (gordallott) said : #1

because of stupid laws passed by the various big media companies, ubuntu can not distribute the required componant to play dvd's, there is a guide here on how to get dvd playback working though: https://help.ubuntu.com/community/RestrictedFormats/PlayingDVDs

jenglish5 (ky0fkq) said : #2

Did that but still no go. I reinstall the whole thing over again including
Ubuntu from scratch but still the same. VLC will not load or do anything
when I click on it. Totem wouldn't play the DVD either.

On Wed, Nov 12, 2008 at 5:45 AM, Gord Allott <
<email address hidden>> wrote:

> Your question #51117 on Ubuntu changed:
> https://answers.edge.launchpad.net/ubuntu/+question/51117
>
> Status: Open => Answered
>
> Gord Allott proposed the following answer:
> because of stupid laws passed by the various big media companies, ubuntu
> can not distribute the required componant to play dvd's, there is a
> guide here on how to get dvd playback working though:
> https://help.ubuntu.com/community/RestrictedFormats/PlayingDVDs
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.edge.launchpad.net/ubuntu/+question/51117/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.edge.launchpad.net/ubuntu/+question/51117
>
> You received this question notification because you are a direct
> subscriber of the question.
>

Play mp3 and dvd under Ubuntu

First please install https://help.ubuntu.com/community/RestrictedFormats

You need to have extra repositories enabled..

Please first enable the multiverse repository:

Open System → Administration → Software sources → [ Tab Ubuntu software ]
enable "Software restrictecd by copyright or legal issue ( multiverse )"
Close and confirm the repository reload.

Type the following command in a terminal (applications → accessories → terminal)

sudo aptitude install vlc

To get better dvd playback first you need to add the medibuntu http://www.medibuntu.org/ repository to your /etc/apt/sources.list file:
here howto add https://help.ubuntu.com/community/Medibuntu here the medibuntu available software list http://packages.medibuntu.org/

Then to install:

sudo apt-get update
sudo aptitude install libdvdread3 libdvdnav4 libdvdcss2
sudo aptitude install non-free-codecs gstreamer0.10-pitfdll w32codecs ubuntu-restricted-extras

give your user password when requested, you don't see nothing when you type it, then press enter.

Hope this helps

Can you help with this problem?

Provide an answer of your own, or ask jenglish5 for more information if necessary.

To post a message you must log in.