Unable to play any songs or movie

Asked by anirbanphys on 2008-11-09

I've installed Ubuntu 8.10 recently. All was fine. But today I've faced a problem,related with playing sound.To play a track with vlc or movie player I've seen the following message

atin@atin-desktop:/media/disk/Songs/Western/Songs/Legendary Songs of Don McLean$ vlc 05\ Crying.mp3
VLC media player 0.9.4 Grishenko
[00000001] main libvlc debug: VLC media player - version 0.9.4 Grishenko - (c) 1996-2008 the VideoLAN team
[00000001] main libvlc debug: libvlc was configured with ./configure '--build=i486-linux-gnu' '--enable-maintaner-mode' '--enable-release' '--prefix=/usr' '--enable-libtool' '--enable-fast-install' '--with-binary-version=1ubuntu3' '--disable-update-check' '--disable-gnome' '--disable-gtk' '--disable-familiar' '--disable-fb' '--enable-ggi' '--enable-sdl' '--enable-esd' '--enable-mad' '--enable-arts' '--enable-jack' '--enable-pulse' '--enable-lirc' '--enable-a52' '--enable-aa' '--enable-dvbpsi' '--enable-mozilla' '--with-mozilla-pkg=libxul-plugin' '--disable-kde' '--enable-mp4' '--enable-dvb' '--disable-satellite' '--enable-ogg' '--enable-vorbis' '--enable-shout' '--enable-qt4' '--disable-slp' '--enable-flac' '--disable-skins' '--disable-basic-skins' '--enable-skins2' '--enable-freetype' '--enable-mkv' '--enable-speex' '--enable-caca' '--enable-live555' '--enable-libmpeg2' '--enable-fribidi' '--enable-cdio' '--enable-mod' '--enable-theora' '--enable-modplug' '--enable-dvdnav' '--enable-gnutls' '--enable-ffmpeg' '--enable-ncurses' '--enable-smb' '--disable-gnomevfs' '--enable-bonjour' '--enable-mpc' '--enable-vcd' '--enable-vcdx' '--enable-notify' '--enable-twolame' '--enable-x264' '--enable-faad' '--disable-zvbi' '--enable-telx' '--enable-mediacontrol-bindings' '--disable-atmo' '--enable-taglib' '--enable-libass' '--enable-libdca' '--enable-alsa' '--enable-dv' '--enable-v4l' '--enable-v4l2' '--enable-pvr' '--enable-svgalib' '--enable-dvd' '--without-dvdcss' 'build_alias=i486-linux-gnu' 'CFLAGS=-g -O2' 'LDFLAGS=-Wl,--as-needed' 'CPPFLAGS=' 'CXXFLAGS=-g -O2'
[00000001] main libvlc debug: translation test: code is "C"
[00000001] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.

Though I've installed all suitable codecs.
Please help.

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu vlc Edit question
Assignee:
No assignee Edit question
Solved by:
anirbanphys
Solved:
2008-11-10
Last query:
2008-11-10
Last reply:
2008-11-09

Might be not reltaed but, can you get me the output of terminal command:

locale

Thank you

anirbanphys (anirbanphys) said : #2

atin@atin-desktop:~$ locale
LANG=en_IN
LC_CTYPE="en_IN"
LC_NUMERIC="en_IN"
LC_TIME="en_IN"
LC_COLLATE="en_IN"
LC_MONETARY="en_IN"
LC_MESSAGES="en_IN"
LC_PAPER="en_IN"
LC_NAME="en_IN"
LC_ADDRESS="en_IN"
LC_TELEPHONE="en_IN"
LC_MEASUREMENT="en_IN"
LC_IDENTIFICATION="en_IN"
LC_ALL=
This is the outputs.

Are you playing song from a removable usb driver...?
can you copy and paste the file into Desktop and play that mp3 form there...?

Thank you

anirbanphys (anirbanphys) said : #4

I was playing from my hard drive and now according to your suggestion I tried to play it from desktop.But nothing happen. I can't heard any sound.Though the VLC window is opening.

Close vlc drag and drop the mp3 song icon on the vlc icon can you play that song...?

anirbanphys (anirbanphys) said : #6

I'm unable to listen any sound.

You was able to listen mp3 from your Ubuntu before...?
if yes
Can you right click with mouse on that mp3 and can you open with a different player...

Thank you

anirbanphys (anirbanphys) said : #8

I did it before but nothing happen,only the corresponding window i opening.

Play mp3 and dvd under Ubuntu

First please install https://help.ubuntu.com/community/RestrictedFormats

You need to have extra repositories enabled..

Please first enable the multiverse repository:

Open System → Administration → Software sources → [ Tab Ubuntu software ]
enable "Software restrictecd by copyright or legal issue ( multiverse )"
Close and confirm the repository reload.

Type the following command in a terminal (applications → accessories → terminal)

sudo aptitude install vlc

To get better dvd playback first you need to add the medibuntu http://www.medibuntu.org/ repository to your /etc/apt/sources.list file:
here howto add https://help.ubuntu.com/community/Medibuntu here the medibuntu available software list http://packages.medibuntu.org/

Then to install:

sudo apt-get update
sudo aptitude install libdvdread3 libdvdnav4 libdvdcss2
sudo aptitude install non-free-codecs gstreamer0.10-pitfdll w32codecs ubuntu-restricted-extras

give your user password when requested, you don't see nothing when you type it, then press enter.

Hope this helps

anirbanphys (anirbanphys) said : #10

ya , it help me.thanks