vlc crashes due to audio preferences?

Asked by pablokal on 2008-10-05

Hardy 8.04
Ati radeon 9800
pentium 4 3 gig mem 1 gig
I get this error message:
VLC media player 0.8.6e Janus

(.:11236): Gtk-WARNING **: Kan themamodule in modulepad: ‘clearlooks’ niet vinden,
[00000345] main audio output warning: output date isn't PTS date, requesting resampling (79748)
[00000345] main audio output warning: buffer is 72748 late, triggering upsampling
[00000343] main private error: option glx-shm does not exist
[00000345] main audio output warning: output date isn't PTS date, requesting resampling (45163)
[00000345] main audio output warning: timing screwed, stopping resampling
[00000345] main audio output warning: buffer is 113890 late, triggering upsampling
libGL error: drmGetMagic failed
libGL error: reverting to (slow) indirect rendering
[00000345] main audio output warning: audio drift is too big (136869), dropping buffer
X Error of failed request: BadMatch (invalid parameter attributes)
  Major opcode of failed request: 143 (GLX)
  Minor opcode of failed request: 5 (X_GLXMakeCurrent)
  Serial number of failed request: 58
  Current serial number in output stream: 58

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu vlc Edit question
Assignee:
No assignee Edit question
Solved by:
pablokal
Solved:
2008-10-05
Last query:
2008-10-05
Last reply:

By setting the VLC audio output to Alsa the faultmessage was reduced to:
(.:11652): Gtk-WARNING **: Kan themamodule in modulepad: ‘clearlooks’ niet vinden,
[00000343] main private error: option glx-shm does not exist
libGL error: drmGetMagic failed
libGL error: reverting to (slow) indirect rendering
X Error of failed request: BadMatch (invalid parameter attributes)
  Major opcode of failed request: 143 (GLX)
  Minor opcode of failed request: 5 (X_GLXMakeCurrent)
  Serial number of failed request: 58
  Current serial number in output stream: 58

In this bug report
https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/251735
a similar fault is reported
having an Ati radeon 9800 I also use fglrx
Installed the Ati driver with EnvyNG.
When I use mplayer for wmv streams I have very bad quality and 3 or 4 instances of mplayer are opened.

I found the solution for this last set of errors here:
http://ubuntuforums.org/showthread.php?t=419018

open vlc (no video, just open it as a program), and do the following:
click - settings > preferences > video
in the bottom right, put a checkmark in "advanced options"
then click - output modules
and change "video output module" from "opengl video output" to "x11 video output".