VLC can't play DVDs

Asked by John Fino on 2008-05-26

I'm running Hardy as a dualboot (from an external hdd) on a p4, 1GB RAM. External DVD is an LG CD-RW; DVD-RW.

I've tried a couple of DVDs (Simpsons, Princess Bride, etc) in VLC and they play really fast through the piracy warnings. Then, it slows to normal but the picture is all messed up (lots of colorful boxes, with maybe some picture, or just a green background). The video and sound (if there are any) stutter. I've followed every faq and recommendation I could find. I have installed gxine; libdvdnav4; libdvdplay0; libdvdread3. All of these are up to date.
Plus I added all the dvd restricted format stuff, all the vlc plugins, lsdvd, and a couple other things I can't remember anymore.
I even tried the regionset, to see if my dvd region was somehow set to not where it should be - but that wouldn't work at all. It gave me an error of:
ERROR: Could not open disc "(null)"!
Please ensure there is a readable CD or DVD in the drive

SMplayer, Totem, and gxine all will play these DVDs. (Though I can't seem to get just plain Mplayer to open a dvd at all.) I'd use them, but the interfaces are not exactly newbie-friendly. At least on VLC you can right-click on the window and jump back to any menu. That doesn't seem to work on these others.

Any help is appreciated.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu vlc Edit question
Assignee:
No assignee Edit question
Solved by:
Jim Hutchinson
Solved:
2008-06-01
Last query:
2008-06-01
Last reply:
2008-05-27
Best Jim Hutchinson (jphutch) said : #1

From what I can tell, you seem to have done the right things. The main reason a DVD won't play out of the box on Ubuntu is that the DVD encryption stuff is not licensed to Ubuntu. You have installed a lot of what seems necessary but you don't mention if you installed libdvdcss2. That is the main package needed to play an encrypted DVD (which is the case for most commercial DVDs). If you haven't, I would check out this (https://help.ubuntu.com/community/Medibuntu) how to and install libdvdcss2. If you have done that, you might want to remove everything and start over. It's possible that you have some things conflicting. I know that on a clean install of Hardy and the addition of libdvdcss2 most DVDs will play just fine. You might also add the ubuntu-restricted-extras package but I don't think that will solve this issue.

John Fino (tauricity) said : #2

I knew I'd forget one - yes, I have libdvdcss2 installed, as well. I also have the ubuntu-restricted-extras. Maybe I just tried one too many things. In anycase, I can't even get into Ubuntu right now - after a recent automatic update I get stuck at Busybox 1.1.3. But that's a different issue. I suspect I will have do a clean install to fix both problems, which is rather annoying, I just got things as I like them - and fixed the damn Flash problem, too.
Thanks for the advice.

John Fino (tauricity) said : #3

I tried a clean install, which worked fine until updates were installed and I restarted. Once again, I can't get back into Ubuntu. I'm going to open another question, and later see if this one can be answered. Thanks for your help, Jim.

Jim Hutchinson (jphutch) said : #4

John,

Sorry to leave you hanging. I haven't had a chance to check back in a couple days. Since DVDs will pretty much play without issue if you have the right packages added, I'm going to guess your issues with DVDs are at least partially related to Ubuntu not working right. I suspect that when you work out whatever issues are causing ubuntu to not start, you will probably have worked out some if not all the reasons for DVDs not working. A good bet is not well supported video or perhaps a hardware issue. I'll check your other ticket and see how things are going. Let us know if this is still an issue when you get ubuntu working right.

John Fino (tauricity) said : #5

Jim, sorry this took awhile, but yes, now I can open DVD w/ vlc. I'm still working on how to get vlc to be the default DVD player; I guess I'm used to the "Open With..." from Windows, which is an awful nice feature. I'm sure I'll figure it out at some point.

Thanks for all your help.

John Fino (tauricity) said : #6

Thanks Jim Hutchinson, that solved my question.

Jim Hutchinson (jphutch) said : #7

John,

Just a little FYI. If you right click a movie file it will give you the "open with" option. For DVDs, there used to be a way to specify which program was default under the system - prefs - removable drives and media. However, it seems missing in Hardy. There is also a tab in nautilus under prefs called media and it will let you set a default program but it too won't show other installed programs like vlc. I've seen some bug reports on this so hopefully it will get fixed soon.

sonjalin (sonja-iki) said : #8

Oh, I'm becoming mad... I have the same problem, vlc doesn't play a DVD properly. The piracy warnings are okay but then "the picture is all messed up (lots of colorful boxes, with maybe some picture, or just a green background). The video and sound (if there are any) stutter."

All the vlc plugins, libdvdnav4, libdvdplay0, libdvdread3, libdvdcss2, regionset and ubuntu-restricted-extras are installed by Synaptic.

I have also done this command:
sudo wget http://www.medibuntu.org/sources.list.d/hardy.list --output-document=/etc/apt/sources.list.d/medibuntu.list

It's a bit difficult for me to read English so maybe I haven't noticed something. Can anyone help?

Columbo1977 (grahammillichap) said : #9

Just in case anyone is still having this problem, after I installed libdvdcss2 VLC was crashing.

I removed and reinstalled VLC and it now plays dvd's fine.

Cheers

Columbo