video problem using vlc on a VGA compatible controller product: UniChrome Pro IGP [VIA P4M890 Chipset]

Asked by Bytan on 2008-05-20

Hi All,
i just installed ubuntu previous OS was ubuntu 7.10 and it was ok.i didnt have any problem like i have now.
i cant watch any video files..i installed vlc and video codecs.i tried to watch videos with both totem and vlc and every time i get the same result..
i heard sound but no video..and the other side, while trying to watch some video, my mouse icon on the screen was moving very very slow..
so i suspected my video card..
i did system->administration->Hardware Testing and then at the step of video testing i only saw a green square instead of a color bars and static..
i have O/B video card:

                description: VGA compatible controller
                product: UniChrome Pro IGP [VIA P4M890 Chipset]

i didnt have any problem with that card on ubuntu 7.04 and 7.10 but now why??
and how do i solve that?
i m sorry its a long question..
any idea??

Question information

English Edit question
Ubuntu vlc Edit question
No assignee Edit question
Solved by:
Gord Allott
Last query:
Last reply:
Best Gord Allott (gordallott) said : #1

if you goto system -> preferences -> multimedia system selector, on the video tab set the plugin output to the 'no Xv', you should get a clear picture when using totem at least (if you can find out how to disable xv in your other media players they should work fine too). im not sure why your graphics card has problems with this version but i would suggest that you file a bug on the situation (so that it gets fixed for the next version)

kureyamu (geecee4u7) said : #2


it all depends on what you mean by "videos" ...

if you mean "moving images" as i think you do, then i have no knowledge to help you

if you mean "films" or "dvds" then what you are lacking is "libdvdcss", which is illegal to use on Linux in the USA because Warner Brothers (the brothers are gangsters, i believe, scarface types) and people like that don't get paid for it by Linux users ... however, if you live in Europe i think you can quite rightly download it, as you should be able to do if as a consumer you bought a dvd player for your computer and then went out to hmv and spent twenty quid on films ... users of Ubuntu and Debian use the .deb file which you can get at:

i'm copying that from a notepad scrawl, you may have to go to and search for the .deb file

download it or copy it a folder in your home directory, right click on it and install with the Debi Installer.

kind regards


Bytan (bytan) said : #3

Thanks Gord Allott, that solved my question.

Bytan (bytan) said : #4

Thanks Guys for your answers

"disabling xv" works for me to watch video files..
but i think for my video card problem, i should file a bug...
Thanks Again..