vlc segfaults or hangs

Asked by gregrwm on 2012-10-20

vlc segfaults when i launch it with:

PULSE_SERVER=localhost:4716 ALSA_PCM_NAME=pulse padsp vlc /dev/cdrom >>/tmp/vlc.$$.ort 2>&1

and if i just launch it with "vlc", it shows a window with a orange striped cone, i select media->open disc, and the window ceases to render, staying all grey.

failures are in freshly installed quantal. works fine in natty.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu vlc Edit question
Assignee:
No assignee Edit question
Solved by:
gregrwm
Solved:
2013-01-19
Last query:
2013-01-19
Last reply:
2012-11-03

What is the output of:

lsb_release -a; uname -a; apt-cache policy vlc

Did you upgrade from Natty to Quantal directly?

gregrwm (gregrwm) said : #2

# lsb_release -a; uname -a; apt-cache policy vlc
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.10
Release: 12.10
Codename: quantal
Linux phovd 3.5.0-17-lowlatency #18-Ubuntu SMP PREEMPT Tue Oct 9 20:05:16 UTC 2012 i686 i686 i686 GNU/Linux
vlc:
  Installed: 2.0.4-0ubuntu1
  Candidate: 2.0.4-0ubuntu1
  Version table:
 *** 2.0.4-0ubuntu1 0
        100 /var/lib/dpkg/status

i installed quantal core in a fresh partition and added lubuntu-desktop.

How did you install VLC. DOesn't look like you used the Ubuntu repo....

sudo apt-get --purge remove vlc
sudo apt-get --purge autoremove
mv ~/.config/vlc ~/.config/vlc_old

Then enable the universe repo in software centre and install vlc and you will get vlc 2.0.3

It will probably work

gregrwm (gregrwm) said : #5

yes it's from ubuntu repo:
ii vlc 2.0.4-0ubuntu1 i386 multimedia player and streamer

i completely reinstalled lubuntu-desktop and vlc from scratch, using quantal netboot instead of quantal core this time, same result.

gregrwm (gregrwm) said : #6

mplayer also fails, see #212367

Did you change the video output method in VLC settings?

gregrwm (gregrwm) said : #8

no. can't get to settings. vlc window doesn't respond. sound is fine if i pass the vlc commandline a stream, but the window doesn't render. i've reported this as Bug #1071593

Try:

sudo add-apt-repository ppa:n-muench/vlc
sudo apt-get update
sudo apt-get --reinstall install vlc

gregrwm (gregrwm) said : #10

should that also work on maya/precise, where i'm having the same problem?

gregrwm (gregrwm) said : #11

works fine after another reinstall. likely problems in prior install: started with ubuntu core, and used --no-install-recommends. did the working reinstall from dvd iso, and no longer used --no-install-recommends.