Ubuntu Precise 12.04 unstable: installing vlc 1.2 using a ppa

Asked by actionparsnip on 2011-12-01

andy@D420:~$ sudo apt-fast -y install vlc
Working...
E: Unable to correct problems, you have held broken packages.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 vlc : Depends: vlc-nox (= 1.2.0~~git20111021+r958-0~r47~precise1) but it is not going to be installed
       Recommends: vlc-plugin-notify (= 1.2.0~~git20111021+r958-0~r47~precise1) but it is not going to be installed
       Recommends: vlc-plugin-pulse (= 1.2.0~~git20111021+r958-0~r47~precise1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
-e
Done! Verify that all packages were installed successfully. If errors are found, run apt-get clean as root and try again using apt-get directly.

andy@D420:~$ sudo apt-get install vlc-nox
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 vlc-nox : Depends: libx264-116 but it is not installable
E: Unable to correct problems, you have held broken packages.
andy@D420:~$ sudo apt-get install libx264-118
Reading package lists... Done
Building dependency tree
Reading state information... Done
libx264-118 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Linux D420 3.2.0-2-generic #5-Ubuntu SMP Mon Nov 28 18:09:32 UTC 2011 i686 i686 i386 GNU/Linux

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu precise (development branch)
Release: 12.04
Codename: precise

vlc:
  Installed: (none)
  Candidate: 1.2.0~~git20111021+r958-0~r47~precise1
  Version table:
     1.2.0~~git20111021+r958-0~r47~precise1 0
        500 http://ppa.launchpad.net/videolan/master-daily/ubuntu/ precise/main i386 Packages
     1.1.12-3 0
        500 http://gb.archive.ubuntu.com/ubuntu/ precise/universe i386 Packages

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu vlc Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2011-12-01
Last query:
2011-12-01
Last reply:
2011-12-01

This question was originally filed as bug #898814.

Micah Gersten (micahg) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs#When%20not%20to%20file%20a%20bug. There is also a vibrant support community available at http://askubuntu.com and you might consider asking your question there.

Micah Gersten (micahg) said : #2

Since this is an issue with an app in a PPA, you should contact the owner of the PPA as Ubuntu cannot fix the issue. It seems like the PPA just needs to be rebuilt with the newer libx264.

No worries