i could not install vlc player

Asked by Sreerag G on 2011-11-02

im new to linux environment.
when i tried to install vlc player i got the error that

 package dependancies cannot be stored

This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.

The following packages have unmet dependencies:

vlc: Depends: vlc-nox (= 1.1.9-1ubuntu1.3) but 1.1.9-1ubuntu1.3 is to be installed
     Depends: libaa1 (>= 1.4p5) but 1.4p5-38build1 is to be installed
     Depends: libavcodec-extra-52 (>= 4:0.6-1~) but it is not going to be installed
     Depends: libavutil-extra-50 (>= 4:0.6-1~) but it is not going to be installed
     Depends: libc6 (>= 2.8) but 2.13-0ubuntu13 is to be installed
     Depends: libfreetype6 (>= 2.2.1) but 2.4.4-1ubuntu2.1 is to be installed
     Depends: libgcc1 (>= 1:4.1.1) but 1:4.5.2-8ubuntu4 is to be installed
     Depends: libqtcore4 (>= 4:4.7.0~beta1) but 4:4.7.2-0ubuntu6.3 is to be installed
     Depends: libqtgui4 (>= 4:4.5.3) but 4:4.7.2-0ubuntu6.3 is to be installed
     Depends: libsdl-image1.2 (>= 1.2.10) but it is not going to be installed
     Depends: libsdl1.2debian (>= 1.2.10-1) but 1.2.14-6.1ubuntu3 is to be installed
     Depends: libstdc++6 (>= 4.5) but 4.5.2-8ubuntu4 is to be installed
     Depends: libtar but it is not going to be installed
     Depends: libva-x11-1 but it is not going to be installed
     Depends: libva1 but it is not going to be installed
     Depends: libxcb-keysyms1 (>= 0.3.6) but it is not going to be installed
     Depends: libxcb-randr0 (>= 1.1) but it is not going to be installed
     Depends: libxcb-xv0 (>= 1.2) but it is not going to be installed
     Depends: zlib1g (>= 1:1.2.3.3.dfsg) but 1:1.2.3.4.dfsg-3ubuntu3 is to be installed

i couldnt understand. somebody say in detail what i hav to do..

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu vlc Edit question
Assignee:
No assignee Edit question
Solved by:
Lalatendu Mohanty
Solved:
2011-11-03
Last query:
2011-11-03
Last reply:
2011-11-02
Best Lalatendu Mohanty (then4way) said : #1

which Ubuntu version you are in? how are u installing it? what was the command u used?

Go to software center inside Ubuntu and try to install vlc from there or go through the link below

http://www.videolan.org/vlc/download-ubuntu.html

Can you give the output of:

apt-cache policy vlc; lsb_release -a

Thanks

Sreerag G (raaloottan) said : #3

actionparsnip:

vlc:
    Installed:(none)
    Candidate: 1.1.9-1ubuntu1.3
    Version table:
         1.1.9-1ubuntu1.3 0
              500 http://in.archiv.ubuntu.com/ubuntu/natty-updates/universe i386 Packages
              500 http://in.security.ubuntu.com/ubuntu/natty-security/universe i386 Packages
1.1.9-1ubuntu1 0
             500 http://in.archiv.ubuntu.com/ubuntu/natty/universe i386 Packages

Sreerag G (raaloottan) said : #4

Thanks Lalatendu Mohanty, that solved my question.