UTF-8 Japanese subtitles not showing

Asked by Pander on 2011-07-24

I'm trying to display Japanese subtitles. In vlc I see only the ASCII and empty rectangles for the kanji. In mplayer I see ä?å? and so on for the kanji.

The subtitles .srt file is made with gaupol and is real UTF-8. Also, this problem has been noted on the Internet by other users.

How can I fix this?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu vlc Edit question
Assignee:
No assignee Edit question
Solved by:
Pander
Solved:
2011-07-24
Last query:
2011-07-24
Last reply:
Pander (pander) said : #1

when using mplayer -utf8 the kanji become underscores.

Pander (pander) said : #2

It is a font problem. The Japanese kanji are not in the default fonts used by mplayer and vlc. This is solved by using mplayer -font FontName of changing the font via Preferences... in vlc. This could be improved by both players by having a fall-back unicode font (when that is installed on the system). Bug report has been filed for vlc.