LG GH22NS50 DVD playback failure Lucid Lynx AMD64

Asked by kiriath-arba on 2011-05-05

Last year I helped a friend set up a desktop running Ubuntu 10.04.

We ran through the routine at https://help.ubuntu.com/community/RestrictedFormats/PlayingDVDs for playing commercial DVDs... straight forward. VLC played DVDs fine for first few months, then started crashing. Sometimes it would play a few minutes of video before the crash, other times it wouldn't play at all. Audio CDs continue to play flawlessly.

The lines from /var/log/syslog below correspond to the time of a recent error (which was failing to start playback at all). Do they offer some clues?

Thanks.

[ 203.010216] ata4.00: revalidation failed (errno=-19)
[ 203.010231] ata4: soft resetting link
[ 203.171421] ata4.01: NODEV after polling detection
[ 203.240970] ata4.00: failed to IDENTIFY (I/O error, err_mask=0x2)
[ 203.240976] ata4.00: revalidation failed (errno=-5)
[ 203.240983] ata4.00: disabled
[ 208.170042] ata4: soft resetting link
[ 208.331419] ata4.01: NODEV after polling detection
[ 208.350217] ata4.00: ATAPI: HL-DT-ST DVDRAM GH22NS50, TN02, max UDMA/100
[ 208.390265] ata4.00: configured for UDMA/100
[ 208.392388] sr 3:0:0:0: [sr0] Unhandled sense code
[ 208.392393] sr 3:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 208.392399] sr 3:0:0:0: [sr0] Sense Key : Hardware Error [current]
[ 208.392406] sr 3:0:0:0: [sr0] Add. Sense: Logical unit communication CRC error (Ultra-DMA/32)
[ 208.392413] sr 3:0:0:0: [sr0] CDB: Read(10): 28 00 00 00 46 28 00 00 40 00
[ 208.392427] end_request: I/O error, dev sr0, sector 71840
[ 208.392433] __ratelimit: 118 callbacks suppressed
[ 208.392438] Buffer I/O error on device sr0, logical block 17960
[ 208.392444] Buffer I/O error on device sr0, logical block 17961
[ 208.392448] Buffer I/O error on device sr0, logical block 17962
[ 208.392452] Buffer I/O error on device sr0, logical block 17963
[ 208.392457] Buffer I/O error on device sr0, logical block 17964
[ 208.392462] Buffer I/O error on device sr0, logical block 17965
[ 208.392466] Buffer I/O error on device sr0, logical block 17966
[ 208.392470] Buffer I/O error on device sr0, logical block 17967
[ 208.392474] Buffer I/O error on device sr0, logical block 17968
[ 208.392478] Buffer I/O error on device sr0, logical block 17969
[ 208.392540] sr 3:0:0:0: rejecting I/O to offline device
[ 208.392553] ata4: EH complete
[ 208.392559] ata4.00: detaching (SCSI 3:0:0:0)
[ 208.464851] scsi 3:0:0:0: rejecting I/O to offline device
[ 208.464864] scsi 3:0:0:0: rejecting I/O to offline device
[ 208.465411] VFS: busy inodes on changed media or resized disk sr0
[ 208.470111] scsi 3:0:0:0: CD-ROM HL-DT-ST DVDRAM GH22NS50 TN02 PQ: 0 ANSI: 5
[ 208.474073] sr1: scsi3-mmc drive: 125x/125x writer dvd-ram cd/rw xa/form2 cdda tray
[ 208.474299] sr 3:0:0:0: Attached scsi CD-ROM sr1
[ 208.474419] sr 3:0:0:0: Attached scsi generic sg1 type 5
[ 210.598795] scsi 3:0:0:0: rejecting I/O to dead device
[ 239.010152] ata4.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
[ 239.010161] sr 3:0:0:0: [sr1] CDB: Read(10): 28 00 00 00 00 12 00 00 02 00
[ 239.010182] ata4.00: cmd a0/01:00:00:00:10/00:00:00:00:00/a0 tag 0 dma 4096 in
[ 239.010184] res 40/00:02:00:0c:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
[ 239.010189] ata4.00: status: { DRDY }
[ 244.061271] ata4: link is slow to respond, please be patient (ready=0)
[ 249.040045] ata4: device not ready (errno=-16), forcing hardreset
[ 249.040056] ata4: soft resetting link
[ 249.200216] ata4.01: NODEV after polling detection
[ 249.270948] ata4.00: failed to IDENTIFY (I/O error, err_mask=0x2)
[ 249.270953] ata4.00: revalidation failed (errno=-5)
[ 254.201281] ata4: soft resetting link
[ 254.361415] ata4.01: NODEV after polling detection
[ 254.420243] ata4.00: configured for UDMA/100
[ 254.422357] ata4: EH complete
[ 255.848423] UDF-fs: Partition marked readonly; forcing readonly mount
[ 255.905731] UDF-fs INFO UDF: Mounting volume '****************', timestamp 1999/11/02 03:56 (12d0)

note: volume details on last line removed

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu vlc Edit question
Assignee:
No assignee Edit question
Solved by:
kiriath-arba
Solved:
2011-05-10
Last query:
2011-05-10
Last reply:

Turned out to be a hardware fault which was solved by replacing faulty sata cable running from mobo to DVD drive.