vlc 1.1.4 in Lucid (since updated to 1.1.8) pops, crackles, snaps, jumps, stutters, skips, emits static, prickles, breaks-up at the start of each new file. After installing w32codecs, it stutters during the playing of a file, then crashes. Help!

Asked by Stephen Hamer on 2011-04-08

My set-up: Ubuntu newbie, running Ubuntu 10.04, installed on an external USB HDD attached to a Samsung N110 netbook.

OK, this is a bit of a long story; I will try to be brief. I installed vlc from the main (multiverse?) repository last September when I first set up my system. But I kept getting an annoying pop, crackle, whatever (choose noun to suit),... at the start of each file I played.

Paid a vist to the videolan web-site. They were a bit cool about the version of vlc in the 10.04 repositories, so I uninstalled the “official” version (1.0.6) and installed version 1.1.4, from this ppa:

ppa:lucid-bleed/ppa

Same problem. Same crackle at the start of each file. Did another Internet search (including a search of this very site). Nothing. What the hell, I thought. It must be my odd set-up – the fact that I am accessing Ubuntu from an ext. USB

So Ignored the problem and used another media-player instead (audacious has always played fine). But it still bugged me, and every now and again I would return to it.

Then last month I installed Ubuntu 10.10 to another partition of my ext. HDD, and again included vlc 1.1.4 – this time from the official repos – in my set-up. Guess what? No crackle. OK, I thought, It can't be my hardware, and it can't be the ppa (else, why did 1.0.6 crackle?); so what else can it be? I began to suspect that It might be a “codec” problem.

Did another Internet search. Found a recent web-page that listed all the prerequisites for “multi-media” in Ubuntu. I had everything it listed – or so I thought. The last item on the list was w32codecs. But I've got that!, I thought, … hardly worth checking. But I hadn't (duh!) – it turned out that I had installed only restricted-extras-39 and libdvdcss. So I installed it, via medibuntu, as required.

Vlc now plays without the crackle at the start of each file, but is no longer stable; it “pops” within files and has developed an alarming tendency to crash.

After I first installed w32codecs, it would crash after 3 or 4 files; so I did a quick uninstall / reinstall switcheroo. I did:

sudo apt-get purge vlc

(which, according to the terminal o/p also got rid of vlc-plugin-pulse and mozilla-plugin-vlc, and a whole bunch of other things)

I then did:

sudo apt-get autoremove

(I was trying, here, to get rid of every last vestige of the “old” vlc. Oh, and between this command and the last, I may have tossed in a restart – no particular reason).

I finished off with:

sudo apt-get install vlc vlc-plugin-pulse mozilla-plugin-vlc

Disappointingly, the “new” vlc came back with my old volume setting (how did it know that?), and its behaviour was only slightly improved: it still crashes, but after a rather longer interval. Sometimes I lose the sound; sometimes the whole package goes kaput! (freezes, then shuts-down).

Looking back at the notes that I made when I first installed vlc way last September, I see that the terminal coughed-up “apt has done something wicked”. Is this relevant? I also have the o/p of dmesg and /var/log/mesages following a recent vlc crash, but these don't seem (to me) to be very helpful.

What is the way forward? It has occurred to me that I don't need the lucid-bleed ppa any more, as the problem doesn't seem to have been the “official” version of vlc in the standard repositories; but how do I get rid of it? Some of my other software seems to have been sourced from this ppa also, so getting rid of it would seem to involve some major surgery.

Or is there some much simpler trick that I am missing? I don't want to get rid of vlc, as (in my opinion) – despite being over-complicated – it offers the best general sound-quality of any media-player – especially when used in conjunction with Ubuntu.

I feel I am close to having the perfect set-up. Just a kid in darkness (52 year-old, actually) looking for some brain to help light the way...

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu vlc Edit question
Assignee:
No assignee Edit question
Solved by:
Stephen Hamer
Solved:
2011-04-11
Last query:
2011-04-11
Last reply:
2011-04-09

Try removing your vlc config and rerun the app to get default settigs

The crash is hard to diagnose from here. It could depend on the type of video you are using or it could be a buggy VLC version.

The cracks and pops could be the netbook not being able to keep up with the video because it is not fast enough or because the USB external hard disk is too slow or transfering too much data at a given time. This is more likely to be the case if your videos are FULL HD.

The win32codecs are risky and your should not install them unless you know you need them to play some video you have. If you have them installed but no video requires them, then it is the same as not having them, so they cause no problems.

marcus aurelius (adbiz) said : #3

netbooks aren't powerful enough to play videos. the processor on mine shot up 20 degrees (dangerously high) when I watched a streaming video off the net. the picture was erratic, it skipped frames and the picture froze often. i have the ubuntu supported ver. 1.0.6 installed. 1.1.8 has additional features that would cause extra strain on your system.

Sorry, I feel I've wasted the time of 3 good people here. w32codecs are needed to play video-files, eh? Oops! I was actually worried about how my audio files were playing. Perhaps I should have made this a clearer.

Well, what did I actually do?

I thought I would re-aquaint myself with what the official vlc package looked and sounded like, so I did a thorough job of uninstalling vlc 1.1.8 with:

sudo apt-get remove - -purge vlc vlc-nox vlc-data vlc-plugin-pulse

I then unchecked the lucid-bleed ppa in synaptic's list of allowed repositories, reloaded (to update its package lists), and then installed vlc 1.0.6 with:

sudo apt-get install vlc vlc-plugin-pulse mozilla-plugin-vlc

This wasn't a good move. A brief examination of the official vlc reminded me why I had got rid of it in the first place: it doesn't display playlist info correctly (a lot of fields are left blank), and there seems to be no way of deleting a whole playlist; the user has to delete items one at a time (or else quit and restart the package). Also, as one of the contributors pointed out, albeit in the form of a warning about 1.1.8, version 1.0.6 is not as feature-rich as its younger brother; it lacks a dedicated facility for accessing Internet-radio, for example.

Worse, on my system, it played lousy -- an echo-chamber effect on some files, and constant popping and hiccuping. But I'm not putting this down as a failure of the supplied software -- I think, somewhere along the line, I've grunged my system (sorry about the technical language -- bear with me newbies). The package held together, though, and didn't crash. Progress?

Got rid of 1.0.6 by uninstalling it, as above, but cleaning out the apt-cache with:

sudo apt-get clean

I then added back the lucid-bleed ppa, updated package lists and reinstalled vlc again (in-out, in-out, shake it all about). The installation was as smooth as silk, but the package sounded awful: same problems as for 1.0.6; but, again, it didn't crash.

Packed it in for the night.

Today, I fired up the package again, and guess what? It's playing fine -- really. No crackling, popping or hiccupping - well, hardly any, just the occasional modest pop on some files (but this may well be a problem with my files which are rather ancient as these things go). The problem (for the moment -- I havn't tested the "new" vlc very extensively yet) seems to have resolved itself.

A big thank you to actionparsnip, Frederico Tello Gentile, and marcus aurelius for taking the time to answer my silly Q.

Edward (undrline) said : #5

So, the problem seemed to go away without any fix for Stephen. For me, the issue occurred when VLC was opened by selecting the file, versus opening the file via an already-opened instance of VLC. Upgrading VLC via ppa:lucid-bleed/ppa appeared to fix it for me.

Well the problem didn't fix itself actually, but it got fixed in the end. The full story is this:

The majority of my music files (which are 'legacy' files, in low bit-rate wma-format) played fine after the re-install; perversely, the clicking problem only affected my newer, higher bit-rate mp3 and ogg files - it was still incredibly annoying, though.

I eventually traced the source of the problem to the pulse-audio plug-in supplied with vlc. This wasn't hard, actually; there are references to vlc's difficulties with pulse-audio all over the Internet.

So the solution was? Actually there wasn't a solution immediately - just a good workaround. This involved changing the audio o/p module in vlc. Details:

Followed this menu-path: vlc -> Tools -> Preferences -> Audio -> Output module. I then chose "ALSA audio" from the drop-down menu, opting, in the menu just below the Output module-menu, to send the o/p directly to my sound-card, bypassing the ALSA sound-server I had previously installed to deal with another problem. This last step was necessary because there is no vlc ALSA-audio plug-in any more, at least for lucid and later distros. (I may have got these technical details wrong - I'm not an expert, I'm not even a well-informed amateur). I then hit Save to confirm these choices* and re-started vlc to activate them.

*they may not e available in some systems.

This solution worked; it got me a click-free vlc media-player. But it wasn't a full solution; there were two difficulties:

1. The above set-up produced a slightly 'colder', 'harsher' sound than I was used to with pulse-audio (what a fuss-pot, eh?)

2. When it was open, vlc hogged the sound card; I couldn't get sound out of any other application. This wasn't a huge problem for me because I very rarely want to listen to more than thing at a time.

The real significance of this solution was that it existed. The fact that the procedure described above instantly got rid of the clicking meant that I had found the cause of the problem, and could forget about it - I think I even went back to using pulse-audio.

Anyway all this is now academic, because, as Edward (above) points out, videolan have finally got round - with version 1.1.12 of vlc - to writing a pulse-audio plugin that works. A big thanks also to the Lucid-bleed ppa for making this version of vlc available in Lucid.

I can now listen to my old, low bit-rate wma files in glorious ubuntu + pulse-audio + vlc sound, which is just as well, because they sound crummy when played with any other set-up.

Happy ending. End of story.